gdb: move to package/devel/
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 10 Oct 2012 13:27:10 +0000 (13:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 10 Oct 2012 13:27:10 +0000 (13:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33706 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/devel/gdb/Makefile [new file with mode: 0644]
package/gdb/Makefile [deleted file]

diff --git a/package/devel/gdb/Makefile b/package/devel/gdb/Makefile
new file mode 100644 (file)
index 0000000..10178b5
--- /dev/null
@@ -0,0 +1,87 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gdb
+PKG_VERSION:=6.8a
+PKG_RELEASE:=4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/gdb
+PKG_MD5SUM:=da20d043e6729f74b909bd507bcae5c9
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-6.8
+
+PKG_BUILD_PARALLEL:=0
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/gdb/Default
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=@!(avr32||cris)
+  URL:=http://www.gnu.org/software/gdb/
+endef
+
+define Package/gdb
+$(call Package/gdb/Default)
+  TITLE:=GNU Debugger
+  DEPENDS+=+libreadline +libncurses
+endef
+
+define Package/gdb/description
+GDB, the GNU Project debugger, allows you to see what is going on `inside'
+another program while it executes -- or what another program was doing at the
+moment it crashed.
+endef
+
+define Package/gdbserver
+$(call Package/gdb/Default)
+  TITLE:=Remote server for GNU Debugger
+endef
+
+define Package/gdbserver/description
+GDBSERVER is a program that allows you to run GDB on a different machine than the
+one which is running the program being debugged.
+endef
+
+# XXX: add --disable-werror to prevent build failure with arm
+CONFIGURE_ARGS+= \
+       --with-system-readline \
+       --without-expat \
+       --disable-werror
+
+CONFIGURE_VARS+= \
+       ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
+
+define Build/Compile
+       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               install-gdb
+endef
+
+define Package/gdb/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdb $(1)/usr/bin/
+endef
+
+define Package/gdbserver/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
+ifneq ($(CONFIG_USE_EGLIBC),)
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(TOOLCHAIN_DIR)/lib/libthread_db* $(1)/usr/lib
+endif
+endef
+
+$(eval $(call BuildPackage,gdb))
+$(eval $(call BuildPackage,gdbserver))
diff --git a/package/gdb/Makefile b/package/gdb/Makefile
deleted file mode 100644 (file)
index 10178b5..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-#
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=gdb
-PKG_VERSION:=6.8a
-PKG_RELEASE:=4
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@GNU/gdb
-PKG_MD5SUM:=da20d043e6729f74b909bd507bcae5c9
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-6.8
-
-PKG_BUILD_PARALLEL:=0
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/gdb/Default
-  SECTION:=utils
-  CATEGORY:=Utilities
-  DEPENDS:=@!(avr32||cris)
-  URL:=http://www.gnu.org/software/gdb/
-endef
-
-define Package/gdb
-$(call Package/gdb/Default)
-  TITLE:=GNU Debugger
-  DEPENDS+=+libreadline +libncurses
-endef
-
-define Package/gdb/description
-GDB, the GNU Project debugger, allows you to see what is going on `inside'
-another program while it executes -- or what another program was doing at the
-moment it crashed.
-endef
-
-define Package/gdbserver
-$(call Package/gdb/Default)
-  TITLE:=Remote server for GNU Debugger
-endef
-
-define Package/gdbserver/description
-GDBSERVER is a program that allows you to run GDB on a different machine than the
-one which is running the program being debugged.
-endef
-
-# XXX: add --disable-werror to prevent build failure with arm
-CONFIGURE_ARGS+= \
-       --with-system-readline \
-       --without-expat \
-       --disable-werror
-
-CONFIGURE_VARS+= \
-       ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
-
-define Build/Compile
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               all
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               install-gdb
-endef
-
-define Package/gdb/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdb $(1)/usr/bin/
-endef
-
-define Package/gdbserver/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
-ifneq ($(CONFIG_USE_EGLIBC),)
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(TOOLCHAIN_DIR)/lib/libthread_db* $(1)/usr/lib
-endif
-endef
-
-$(eval $(call BuildPackage,gdb))
-$(eval $(call BuildPackage,gdbserver))