ltq-ifxos: fix broken autoconf invocation
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Jan 2015 16:53:45 +0000 (16:53 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 11 Jan 2015 16:53:45 +0000 (16:53 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43932 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/lantiq/ltq-ifxos/Makefile

index 0a0fc9a..3758752 100644 (file)
@@ -15,6 +15,7 @@ PKG_MD5SUM:=bc107f9d8ff6bed4c2760a2817bbb029
 PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 PKG_USE_MIPS16:=0
+PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -36,11 +37,6 @@ CONFIGURE_ARGS += \
        --enable-kernelincl="$(LINUX_DIR)/include" \
        --enable-add_drv_cflags="-fno-pic -mno-abicalls -mlong-calls -G 0"
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); aclocal && autoconf && automake)
-       $(call Build/Configure/Default)
-endef
-
 ifdef CONFIG_TARGET_lantiq
   define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/{lib,include/ifxos}