ar71xx: image: reserve 4 erase blocks on the TP-Link devices
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 25 Jan 2014 18:12:13 +0000 (18:12 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 25 Jan 2014 18:12:13 +0000 (18:12 +0000)
This ensures that the generated images will have enough erase
blocks for JFFS2.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39397 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index d5aee07..1f181f4 100644 (file)
@@ -620,11 +620,13 @@ define Image/Build/TPLINKOLD
        ) > $(KDIR_TMP)/kernel-$(2).bin
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
                -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION)\
+               -X 0x40000 \
                -k $(KDIR_TMP)/kernel-$(2).bin \
                -r $(KDIR)/root.$(1) \
                -o $(call factoryname,$(1),$(2))
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
                -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) -s\
+               -X 0x40000 \
                -k $(KDIR_TMP)/kernel-$(2).bin \
                -r $(KDIR)/root.$(1) \
                -o $(call sysupname,$(1),$(2))
@@ -650,12 +652,14 @@ define Image/Build/TPLINK
        ) > $(KDIR_TMP)/kernel-$(2).bin
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
                -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION)\
+               -X 0x40000 \
                -k $(KDIR_TMP)/kernel-$(2).bin \
                -r $(KDIR)/root.$(1) \
                -a $(call rootfs_align,$(1)) -j \
                -o $(call factoryname,$(1),$(2))
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
                -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) -s\
+               -X 0x40000 \
                -k $(KDIR_TMP)/kernel-$(2).bin \
                -r $(KDIR)/root.$(1) \
                -a $(call rootfs_align,$(1)) -j \
@@ -676,12 +680,14 @@ Image/Build/TPLINK-LZMA/buildkernel=$(call PatchKernelLzma,$(2),$(3))
 define Image/Build/TPLINK-LZMA
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
                -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) $(7) \
+               -X 0x40000 \
                -k $(KDIR_TMP)/vmlinux-$(2).bin.lzma \
                -r $(KDIR)/root.$(1) \
                -a $(call rootfs_align,$(1)) -j \
                -o $(call factoryname,$(1),$(2))
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
                -H $(4) -W $(5) -F $(6) -N OpenWrt -V $(REVISION) $(7) -s \
+               -X 0x40000 \
                -k $(KDIR_TMP)/vmlinux-$(2).bin.lzma \
                -r $(KDIR)/root.$(1) \
                -a $(call rootfs_align,$(1)) -j \