fix kernel build with quilt
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Sep 2007 04:21:21 +0000 (04:21 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 10 Sep 2007 04:21:21 +0000 (04:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8727 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk
include/quilt.mk

index b2a7476..788e3f2 100644 (file)
@@ -43,7 +43,9 @@ else
   TESTING:=$(if $(findstring -rc,$(LINUX_VERSION)),/testing,)
   LINUX_SITE:=@KERNEL/linux/kernel/v$(KERNEL)$(TESTING) \
 
-  PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  ifneq ($(TARGET_BUILD),1)
+    PKG_BUILD_DIR ?= $(KERNEL_BUILD_DIR)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+  endif
 endif
 
 ifneq (,$(findstring uml,$(BOARD)))
index 3a6f0dc..c0a868f 100644 (file)
@@ -5,7 +5,7 @@
 # See /LICENSE for more information.
 #
 
-ifeq ($(KERNEL_BUILD),1)
+ifeq ($(TARGET_BUILD),1)
   PKG_BUILD_DIR:=$(LINUX_DIR)
 endif
 PATCH_DIR?=./patches