[package] ppp: interpret "demand" option as timeout in seconds (#7517)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Jun 2010 18:11:04 +0000 (18:11 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Jun 2010 18:11:04 +0000 (18:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21903 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ppp/Makefile
package/ppp/files/ppp.sh

index d7dcc65..e0724ff 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ppp
 PKG_VERSION:=2.4.4
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
index 53cfb1b..46a66c9 100644 (file)
@@ -92,11 +92,11 @@ start_pppd() {
        }
 
        local demand
-       config_get_bool demand "$cfg" demand 0
+       config_get demand "$cfg" demand 0
 
        local demandargs
-       [ "$demand" -eq 1 ] && {
-               demandargs="precompiled-active-filter /etc/ppp/filter demand idle"
+       [ "$demand" -gt 0 ] && {
+               demandargs="precompiled-active-filter /etc/ppp/filter demand idle $demand"
                [ "$has_dns" -eq 0 ] && add_dns "$cfg" 1.1.1.1
        } || {
                demandargs="persist"