bcm63xx: Add defconfigs.
authorcshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Nov 2010 22:04:19 +0000 (22:04 +0000)
committercshore <cshore@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Nov 2010 22:04:19 +0000 (22:04 +0000)
Port the mechanism for different default configurations from ar71xx and
use the old configuration as the default configuration. This should have
no functional differences to before.
While we are at it, remove the obsolete nat option.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@24185 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/base-files.mk [new file with mode: 0644]
target/linux/brcm63xx/base-files/etc/config/network [deleted file]
target/linux/brcm63xx/base-files/etc/defconfig/generic/network [new file with mode: 0644]
target/linux/brcm63xx/base-files/etc/init.d/defconfig [new file with mode: 0755]

diff --git a/target/linux/brcm63xx/base-files.mk b/target/linux/brcm63xx/base-files.mk
new file mode 100644 (file)
index 0000000..d6682bd
--- /dev/null
@@ -0,0 +1,5 @@
+define Package/base-files/install-target
+       rm -f $(1)/etc/config/network
+endef
+
+
diff --git a/target/linux/brcm63xx/base-files/etc/config/network b/target/linux/brcm63xx/base-files/etc/config/network
deleted file mode 100644 (file)
index c15fdd8..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright (C) 2008 OpenWrt.org
-
-config interface loopback
-        option ifname   lo
-        option proto    static
-        option ipaddr   127.0.0.1
-        option netmask  255.0.0.0
-
-config interface lan
-        option type     bridge
-        option ifname   eth1
-        option proto    static
-        option ipaddr   192.168.1.1
-        option netmask  255.255.255.0
-        option nat      1
-
-config interface wan
-       option ifname   eth0
-       option proto    dhcp
diff --git a/target/linux/brcm63xx/base-files/etc/defconfig/generic/network b/target/linux/brcm63xx/base-files/etc/defconfig/generic/network
new file mode 100644 (file)
index 0000000..bc2c69b
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright (C) 2008 OpenWrt.org
+
+config interface loopback
+        option ifname   lo
+        option proto    static
+        option ipaddr   127.0.0.1
+        option netmask  255.0.0.0
+
+config interface lan
+        option type     bridge
+        option ifname   eth1
+        option proto    static
+        option ipaddr   192.168.1.1
+        option netmask  255.255.255.0
+
+config interface wan
+       option ifname   eth0
+       option proto    dhcp
diff --git a/target/linux/brcm63xx/base-files/etc/init.d/defconfig b/target/linux/brcm63xx/base-files/etc/init.d/defconfig
new file mode 100755 (executable)
index 0000000..dac9c23
--- /dev/null
@@ -0,0 +1,18 @@
+#!/bin/sh /etc/rc.common
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+
+START=05
+
+start() {
+       local board=$(awk 'BEGIN{FS="[ \t:/]+"} /system type/ {print $4}' /proc/cpuinfo)
+
+       [ ! -d /etc/defconfig/$board ] && board="generic"
+
+       for f in $( ls /etc/defconfig/$board ); do
+               if [ ! -e /etc/config/$f ]; then
+                       cp /etc/defconfig/$board/$f /etc/config/
+               fi
+       done
+}