fixes etables CONFIG_* selection for >= 2.6.25, fixes #3674
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jul 2008 00:58:36 +0000 (00:58 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jul 2008 00:58:36 +0000 (00:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12002 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netfilter.mk

index 802edac..31c6287 100644 (file)
@@ -301,13 +301,13 @@ endef
 
 $(eval $(call KernelPackage,arptables))
 
-
 define KernelPackage/ebtables
   SUBMENU:=$(NF_MENU)
   TITLE:=Bridge firewalling modules
   DEPENDS:=@LINUX_2_6
   FILES:=$(LINUX_DIR)/net/bridge/netfilter/*.$(LINUX_KMOD_SUFFIX)
-  KCONFIG:=CONFIG_BRIDGE_NF_EBTABLES
+  KCONFIG:=CONFIG_BRIDGE_NETFILTER=y \
+       CONFIG_BRIDGE_NF_EBTABLES
   AUTOLOAD:=$(call AutoLoad,40,$(notdir $(patsubst %.ko,%,ebtables.ko $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebtable_*.$(LINUX_KMOD_SUFFIX)) $(wildcard $(LINUX_DIR)/net/bridge/netfilter/ebt_*.$(LINUX_KMOD_SUFFIX)))))
 endef