kernel: update 3.10 to 3.10.13
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Sep 2013 07:19:21 +0000 (07:19 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Sep 2013 07:19:21 +0000 (07:19 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38228 3c298f89-4303-0410-b956-a3cf2f4a3e73

28 files changed:
include/kernel-version.mk
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-3.10/200-MIPS-ath79-fix-ar933x-watchdog-clock.patch [deleted file]
target/linux/avr32/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/generic/patches-3.10/941-ocf_20120127.patch
target/linux/imx23/Makefile
target/linux/imx6/Makefile
target/linux/ixp4xx/Makefile
target/linux/lantiq/Makefile
target/linux/lantiq/patches-3.10/0001-MIPS-lantiq-add-pcie-driver.patch
target/linux/lantiq/patches-3.10/0032-USB-fix-roothub-for-IFXHCD.patch
target/linux/malta/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/octeon/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/x86/alix2/target.mk
target/linux/xburst/Makefile
target/linux/xburst/patches-3.10/003-NAND-Add-support-for-subpage-reads-for-NAND_ECC_HW_O.patch

index 52bb309..d63ab65 100644 (file)
@@ -17,8 +17,8 @@ endif
 ifeq ($(LINUX_VERSION),3.9.11)
   LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
 endif
-ifeq ($(LINUX_VERSION),3.10.12)
-  LINUX_KERNEL_MD5SUM:=16e43b3c9957cf5af44863d6809efe38
+ifeq ($(LINUX_VERSION),3.10.13)
+  LINUX_KERNEL_MD5SUM:=64ffe74249442fd7452d12348955ccfd
 endif
 
 # disable the md5sum check for unknown kernel versions
index e80cc59..cabcf04 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs targz mips16
 CPU_TYPE=34kc
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
diff --git a/target/linux/ar71xx/patches-3.10/200-MIPS-ath79-fix-ar933x-watchdog-clock.patch b/target/linux/ar71xx/patches-3.10/200-MIPS-ath79-fix-ar933x-watchdog-clock.patch
deleted file mode 100644 (file)
index b3a3cd3..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-From: Felix Fietkau <nbd@openwrt.org>
-Subject: [PATCH] MIPS: ath79: fix ar933x watchdog clock
-
-Signed-off-by: Felix Fietkau <nbd@openwrt.org>
---- a/arch/mips/ath79/clock.c
-+++ b/arch/mips/ath79/clock.c
-@@ -164,7 +164,7 @@ static void __init ar933x_clocks_init(vo
-               ath79_ahb_clk.rate = freq / t;
-       }
--      ath79_wdt_clk.rate = ath79_ref_clk.rate;
-+      ath79_wdt_clk.rate = ath79_ahb_clk.rate;
-       ath79_uart_clk.rate = ath79_ref_clk.rate;
- }
index abcff6d..a7387e3 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 60701e5..c39c020 100644 (file)
@@ -14,7 +14,7 @@ MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 17606f4..0bd3f2f 100644 (file)
@@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 CPU_TYPE:=arm1176jzf-s
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
index 535e703..3ad04fe 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += swconfig kmod-diag wpad-mini nvram
index 1fcbc81..f4aa477 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 30066ab..8568323 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CPU_TYPE:=fa526
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index a177fde..dc16d01 100644 (file)
  void generate_random_uuid(unsigned char uuid_out[16]);
 --- a/kernel/pid.c
 +++ b/kernel/pid.c
-@@ -422,6 +422,7 @@ void transfer_pid(struct task_struct *ol
+@@ -423,6 +423,7 @@ void transfer_pid(struct task_struct *ol
        new->pids[type].pid = old->pids[type].pid;
        hlist_replace_rcu(&old->pids[type].node, &new->pids[type].node);
  }
index 439b01f..fd4ffb2 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=ext4 rtc usb gpio
 CPU_TYPE:=arm926ej-s
 
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 KERNELNAME:="zImage dtbs"
 
 define Target/Description
index eed8088..6214731 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 7bc839a..86acd34 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index fa98788..9ac2a13 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs
 SUBTARGETS=xway xrx200 ase falcon
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 CPU_TYPE:=mips32r2
 
index ce1412a..9329e15 100644 (file)
@@ -5527,7 +5527,7 @@ Subject: [PATCH 01/34] MIPS: lantiq: add pcie driver
                                         unsigned long type);
 --- a/include/linux/pci_ids.h
 +++ b/include/linux/pci_ids.h
-@@ -1042,6 +1042,12 @@
+@@ -1044,6 +1044,12 @@
  #define PCI_DEVICE_ID_SGI_LITHIUM     0x1002
  #define PCI_DEVICE_ID_SGI_IOC4                0x100a
  
index 559a6b8..22526cf 100644 (file)
@@ -20,7 +20,7 @@ Subject: [PATCH 32/34] USB: fix roothub for IFXHCD
  choice
 --- a/drivers/usb/core/hub.c
 +++ b/drivers/usb/core/hub.c
-@@ -4041,7 +4041,7 @@ hub_port_init (struct usb_hub *hub, stru
+@@ -4036,7 +4036,7 @@ hub_port_init (struct usb_hub *hub, stru
                udev->ttport = hdev->ttport;
        } else if (udev->speed != USB_SPEED_HIGH
                        && hdev->speed == USB_SPEED_HIGH) {
index c05a302..853013a 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 DEVICE_TYPE:=developerboard
 
index 278cdee..bbb9c01 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index bf3c5f8..611cafb 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index a9fd5ab..a861ca2 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=octeon
 CPU_CFLAGS_octeon:=-march=octeon
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 947c8eb..cac70d8 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 6c48c01..78e840e 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 
index 9a13a2c..fec7ddb 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt305x rt3883 mt7620a rt288x
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 1a30bef..c37123a 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=pci targz broken
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 7088bc3..ee5dfc5 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 DEVICE_TYPE:=developerboard
 
index fce9c90..2d789a1 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 CS5535_MASK:=0x0b000042
 
 CPU_TYPE := geode
index b799b7c..0de518b 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.10.12
+LINUX_VERSION:=3.10.13
 
 DEVICE_TYPE=other
 
index 1754de7..4d2c88e 100644 (file)
@@ -106,7 +106,7 @@ Signed-off-by: Lars-Peter Clausen <lars@metafoo.de>
                        else
                                ret = chip->ecc.read_page(mtd, chip, bufpoi,
                                                          oob_required, page);
-@@ -3475,8 +3544,13 @@ int nand_scan_tail(struct mtd_info *mtd)
+@@ -3477,8 +3546,13 @@ int nand_scan_tail(struct mtd_info *mtd)
                                   "hardware ECC not possible\n");
                        BUG();
                }