fix potential rootfs owner/group mismatch (tgz root only, patch from #4562)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Feb 2009 17:19:29 +0000 (17:19 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Feb 2009 17:19:29 +0000 (17:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14569 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 2b239ca..7de2d63 100644 (file)
@@ -62,7 +62,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
 
   ifeq ($(CONFIG_TARGET_ROOTFS_TGZ),y)
     define Image/mkfs/tgz
-               $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --owner=root --group=root -C $(TARGET_DIR)/ .
+               $(TAR) -zcf $(BIN_DIR)/openwrt-$(BOARD)-rootfs.tgz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
     endef
   endif