ramips: add support for Omnima MiniEMBWiFi board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2011 20:51:26 +0000 (20:51 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Dec 2011 20:51:26 +0000 (20:51 +0000)
This patch adds support for the Omnima MiniEMBWiFi
Ralink RT3050F based board.

Based on a patch by Ivan Ignjatic <ivan at omnima.co.uk>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29533 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-omni-emb.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-2.6.39

index ba4787b..e0a4a39 100755 (executable)
@@ -48,6 +48,9 @@ get_status_led() {
        nw718)
                status_led="nw718:amber:cpu"
                ;;
+       omni-emb)
+               status_led="emb:green:status"
+               ;;
        pwh2004)
                status_led="pwh2004:green:power"
                ;;
index 920c8a3..d6db35c 100644 (file)
@@ -53,6 +53,7 @@ case "$FIRMWARE" in
        pwh2004 | \
        nbg-419n | \
        nw718 | \
+       omni-emb | \
        rt-n15 | \
        v22rw-2x2 | \
        wcr-150gn | \
index 4261a6c..0518b7b 100644 (file)
@@ -20,7 +20,8 @@ preinit_set_mac_address() {
                 ifconfig eth0 hw ether $mac 2>/dev/null
                 ;;
        hw550-3g |\
-       nbg-419n)
+       nbg-419n |\
+       omni-emb)
                mac=$(ramips_get_mac_binary factory 40)
                ifconfig eth0 hw ether $mac 2>/dev/null
                ;;
index b41a153..7d45bde 100755 (executable)
@@ -80,6 +80,9 @@ ramips_board_name() {
        *"NW718")
                name="nw718"
                ;;
+       *"Omnima MiniEMBWiFi")
+               name="omni-emb"
+               ;;
        *"PWH2004")
                name="pwh2004"
                ;;
index 4cb4c50..03a1e7b 100755 (executable)
@@ -23,6 +23,7 @@ platform_check_image() {
        mofi3500-3gn | \
        nbg-419n | \
        nw718 | \
+       omni-emb | \
        rt-g32-b1 | \
        rt-n15 | \
        v22rw-2x2 | \
index 72cd9c7..211f72c 100644 (file)
@@ -32,6 +32,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_HW550_3G,           /* Aztech HW550-3G */
        RAMIPS_MACH_MOFI3500_3GN,       /* MoFi Network MOFI3500-3GN */
        RAMIPS_MACH_NBG_419N,           /* ZyXEL NBG-419N */
+       RAMIPS_MACH_OMNI_EMB,           /* Omnima MiniEMBWiFi */
        RAMIPS_MACH_PWH2004,            /* Prolink 2004H / Abocom 5205 */
        RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
        RAMIPS_MACH_WCR150GN,           /* Sparklan WCR-150GN */
index e8a1a25..cf8ede3 100644 (file)
@@ -56,6 +56,11 @@ config RT305X_MACH_BC2
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_OMNI_EMB
+       bool "Omnima MiniEMBWiFi"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_PWH2004
        bool "Prolink PWH2004 / Abocom WR5205 support (32M RAM, 8M flash)"
        select RALINK_DEV_GPIO_BUTTONS
index 76a7830..be3d308 100644 (file)
@@ -20,6 +20,7 @@ obj-$(CONFIG_RT305X_MACH_HW550_3G)    += mach-hw550-3g.o
 obj-$(CONFIG_RT305X_MACH_MOFI3500_3GN) += mach-mofi3500-3gn.o
 obj-$(CONFIG_RT305X_MACH_NBG_419N)     += mach-nbg-419n.o
 obj-$(CONFIG_RT305X_MACH_NW718)                += mach-nw718.o
+obj-$(CONFIG_RT305X_MACH_OMNI_EMB)     += mach-omni-emb.o
 obj-$(CONFIG_RT305X_MACH_PWH2004)      += mach-pwh2004.o
 obj-$(CONFIG_RT305X_MACH_RT_G32_REVB)  += mach-rt-g32-revb.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-omni-emb.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-omni-emb.c
new file mode 100644 (file)
index 0000000..87acf4d
--- /dev/null
@@ -0,0 +1,111 @@
+/*
+ *  Omnima MiniEMBWiFi board support
+ *
+ *  Copyright (C) 2011 Johnathan Boyce <jon.boyce@globalreach.eu.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+#include <linux/gpio.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define OMNI_EMB_GPIO_BUTTON_RESET     12 /* active low */
+
+#define OMNI_EMB_BUTTONS_POLL_INTERVAL 20
+
+#define OMNI_EMB_GPIO_LED_STATUS       9
+#define OMNI_EMB_GPIO_LED_WLAN         14
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition emb_partitions[] = {
+       {
+               .name   = "uboot",
+               .offset = 0,
+               .size   = 0x030000,
+       }, {
+               .name   = "uboot-config",
+               .offset = 0x030000,
+               .size   = 0x040000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x050000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "linux",
+               .offset = 0x050000,
+               .size   = 0x100000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x150000,
+               .size   = 0x6B0000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data omni_emb_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(emb_partitions),
+       .parts          = emb_partitions,
+#endif
+};
+
+static struct gpio_led omni_emb_leds_gpio[] __initdata = {
+       {
+               .name           = "emb:green:status",
+               .gpio           = OMNI_EMB_GPIO_LED_STATUS,
+               .active_low     = 1,
+       }, {
+               .name           = "emb:green:wlan",
+               .gpio           = OMNI_EMB_GPIO_LED_WLAN,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_button omni_emb_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = OMNI_EMB_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }
+};
+
+static void __init omni_emb_init(void)
+{
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(omni_emb_leds_gpio),
+                               omni_emb_leds_gpio);
+       ramips_register_gpio_buttons(-1, OMNI_EMB_BUTTONS_POLL_INTERVAL,
+                               ARRAY_SIZE(omni_emb_gpio_buttons),
+                               omni_emb_gpio_buttons);
+
+       rt305x_register_flash(0, &omni_emb_flash_data);
+       rt305x_register_ethernet();
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+       rt305x_register_usb();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_OMNI_EMB, "OMNI-EMB", "Omnima MiniEMBWiFi",
+            omni_emb_init);
index 24f5966..4f92d30 100644 (file)
@@ -139,6 +139,12 @@ define Image/Build/Template/NW718
        $(call BuildFirmware/NW718,$(1),$(2),board=$(3),mtdlayout_nw718,851968,2949120)
 endef
 
+console_OMNIEMB=ttyS1,57600
+mtdlayout_ONMIEMB=mtdparts=physmap-flash.0:192k(u-boot)ro,64k(u-boot-env)ro,64k(factory)ro,1024k(kernel),6848k(rootfs),7872k@0x50000(firmware)
+define Image/Build/Template/OMNIEMB
+       $(call BuildFirmware/Generic,$(1),$(2),board=$(3) console=$(console_OMNIEMB),mtdlayout_OMNIEMB,1048576,7012352)
+endef
+
 define Image/Build/Profile/DIR300B1
        $(call Image/Build/Template/DIR300B1,$(1),dir-300-b1,DIR-300-B1,wrgn23_dlwbr_dir300b)
        $(call Image/Build/Template/DIR300B1,$(1),dir-600-b1,DIR-600-B1,wrgn23_dlwbr_dir600b)
@@ -173,6 +179,10 @@ define Image/Build/Profile/NW718
        $(call Image/Build/Template/NW718,$(1),nw718,NW718)
 endef
 
+define Image/Build/Profile/OMNIEMB
+       $(call Image/Build/Template/OMNIEMB,$(1),omni-emb,OMNI-EMB)
+endef
+
 define Image/Build/Profile/PWH2004
        $(call Image/Build/Template/GENERIC_8M,$(1),pwh2004,PWH2004)
 endef
@@ -248,6 +258,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/V22RW2X2,$(1))
        $(call Image/Build/Profile/NBG419N,$(1))
        $(call Image/Build/Profile/NW718,$(1))
+       $(call Image/Build/Profile/OMNIEMB,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
index 5d7e4b1..e3553e1 100644 (file)
@@ -100,6 +100,7 @@ CONFIG_RT305X_MACH_HW550_3G=y
 CONFIG_RT305X_MACH_MOFI3500_3GN=y
 CONFIG_RT305X_MACH_NBG_419N=y
 CONFIG_RT305X_MACH_NW718=y
+CONFIG_RT305X_MACH_OMNI_EMB=y
 CONFIG_RT305X_MACH_PWH2004=y
 CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_V22RW_2X2=y