kernel: deactivate the vdso gettimeofday function.
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Feb 2016 22:31:51 +0000 (22:31 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Feb 2016 22:31:51 +0000 (22:31 +0000)
The vdso version of this function has some problems with the cache.
Very often it works on dated data which causes problem. We are
currently working on fixing this in upstream Linux kernel.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48787 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/generic/patches-4.4/340-MIPS-deactivate-gettimeofday-vdso.patch [new file with mode: 0644]

diff --git a/target/linux/generic/patches-4.4/340-MIPS-deactivate-gettimeofday-vdso.patch b/target/linux/generic/patches-4.4/340-MIPS-deactivate-gettimeofday-vdso.patch
new file mode 100644 (file)
index 0000000..a77bdf8
--- /dev/null
@@ -0,0 +1,9 @@
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -1,5 +1,5 @@
+ # Objects to go into the VDSO.
+-obj-vdso-y := elf.o gettimeofday.o sigreturn.o
++obj-vdso-y := elf.o sigreturn.o
+ # Common compiler flags between ABIs.
+ ccflags-vdso := \