fix conversion to buildroot-ng.
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 May 2006 01:39:50 +0000 (01:39 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 May 2006 01:39:50 +0000 (01:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3835 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/udev/Makefile

index 620aa1a..c7e5f44 100644 (file)
@@ -5,7 +5,6 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=udev
 PKG_VERSION:=077
 PKG_RELEASE:=1
-PKG_MD5SUM:=61ec646daf7795e9777e8f33975408fe
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -15,8 +14,11 @@ PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
        http://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
        ftp://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/ \
        http://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
+PKG_MD5SUM:=61ec646daf7795e9777e8f33975408fe
 PKG_CAT:=bzcat
 
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
 include $(TOPDIR)/package/rules.mk
 
 define Package/udev
@@ -30,20 +32,32 @@ the /dev directory, or it renames network interfaces. \\\
 URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
 endef
 
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CROSS="$(TARGET_CROSS)" \
+               STRIP="/bin/true" \
+               OPTFLAGS="$(TARGET_CFLAGS)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               INSTALL="install -c" \
+               all install
+endef
+
 define Package/udev/install
        install -d -m0775 $(1)/etc/udev
+       $(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(1)/etc/udev/
        install -d -m0775 $(1)/lib/udev
        install -d -m0775 $(1)/sbin/
-       install -d -m0775 $(1)/usr/bin/
-       install -d -m0775 $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(1)/etc/udev/
        $(CP) $(PKG_INSTALL_DIR)/sbin/udev $(1)/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/udevsend $(1)/sbin/
        $(CP) $(PKG_INSTALL_DIR)/sbin/udevstart $(1)/sbin/
+       install -d -m0775 $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
+       install -d -m0775 $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(1)/usr/sbin/
 endef