ipv6-support: Fix typo in dhcpv6-script
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 31 Dec 2012 09:38:59 +0000 (09:38 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 31 Dec 2012 09:38:59 +0000 (09:38 +0000)
* thanks to KarlHegbloom for reporting

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34940 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/ipv6-support/Makefile
package/network/ipv6/ipv6-support/files/dhcpv6.sh

index 43ebb1f..7e2e5e9 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipv6-support
-PKG_VERSION:=2012-12-30
+PKG_VERSION:=2012-12-31
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 25355be..299cf99 100755 (executable)
@@ -30,7 +30,7 @@ setup_prefix_fallback "$fallback" "$network" "$device"
 
 
 # Operations in case of success
-[ "$state" == "timeout" || "$state" == "unbound" ] && exit 0
+[ "$state" == "timeout" -o "$state" == "unbound" ] && exit 0
 
 local peerdns
 config_get_bool peerdns "$network" peerdns 1