add ncurses to prereq checks
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Jul 2006 23:02:37 +0000 (23:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Jul 2006 23:02:37 +0000 (23:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4244 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq.mk

index 6642ce4..e514855 100644 (file)
@@ -84,6 +84,16 @@ $(eval $(call Require,working-g++, \
        No working GNU C++ Compiler (g++) was found on your system. \
 ))
 
+define Require/ncurses
+       echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
+               gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out -lncurses -
+endef
+
+$(eval $(call Require,ncurses, \
+       No ncurses development files were not found on your system. \
+))
+
+
 define Require/zlib
        echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
                gcc -include zlib.h -x c -o $(TMP_DIR)/a.out -lz -