ramips: rt305x: add initial support for Tenda W306R V2.0
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Apr 2012 12:30:40 +0000 (12:30 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Apr 2012 12:30:40 +0000 (12:30 +0000)
More device info at: http://wiki.openwrt.org/toh/tenda/w306r

Signed-off-by: David Pearce <David_18051985@hotmail.com.au>
[juhosg: fix checkpatch errors, remove kmod-phy and luci-ssl packages
from the profile, change broken GPIO number]

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31396 3c298f89-4303-0410-b956-a3cf2f4a3e73

14 files changed:
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/leds
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-3.2
target/linux/ramips/rt305x/profiles/tenda.mk [new file with mode: 0644]

index 95f608a..2d351d6 100755 (executable)
@@ -81,6 +81,9 @@ get_status_led() {
        v22rw-2x2)
                status_led="v22rw-2x2:green:security"
                ;;
+       w306r-v20)
+               status_led="w306r:green:sys"
+               ;;
        w502u)
                status_led="alfa:blue:wps"
                ;;
index 62788cd..34821ec 100644 (file)
@@ -65,6 +65,7 @@ case "$FIRMWARE" in
        sl-r7205 | \
        v11st-fe | \
        v22rw-2x2 | \
+       w306r-v20 | \
        w502u | \
        wcr-150gn | \
        whr-g300n | \
index d8f3c0c..ba6ea60 100755 (executable)
@@ -66,6 +66,9 @@ case $board in
        v11st-fe)
                set_wifi_led "rt2800pci-phy0::radio"
                ;;
+       w306r-v20)
+               set_wifi_led "rt2800pci-phy0::radio"
+               ;;
        w502u)
                set_usb_led "alfa:blue:usb"
                set_wifi_led "rt2800pci-phy0::radio"
index dc2221f..81c12de 100755 (executable)
@@ -55,6 +55,7 @@ ramips_setup_interfaces()
                ;;
 
        freestation5 | \
+       w306r-v20 | \
        wcr-150gn)
                ucidef_set_interfaces_lan_wan "eth0.2" "eth0.1"
                ;;
@@ -96,6 +97,11 @@ ramips_setup_macs()
                wan_mac=$(/usr/sbin/maccalc add "$lan_mac" 1)
                ;;
 
+       w306r-v20)
+               lan_mac=$(ramips_get_mac_binary factory 4)
+               wan_mac=$(/usr/sbin/maccalc add "$lan_mac" 5)
+               ;;
+
        dir-300-b1 |\
        dir-300-b2 |\
        dir-600-b1)
index f523d69..bd5de41 100644 (file)
@@ -28,6 +28,7 @@ preinit_set_mac_address() {
        hw550-3g |\
        nbg-419n |\
        omni-emb |\
+       w306r-v20 |\
        w502u    |\
        wl-330n |\
        wr6202 |\
index 1298ebd..045d952 100755 (executable)
@@ -134,6 +134,9 @@ ramips_board_name() {
        *"Sitecom WL-351 v1 002")
                name="wl-351"
                ;;
+       *"Tenda W306R V2.0")
+               name="w306r-v20"
+               ;;
        *"Ralink V11ST-FE")
                name="v11st-fe"
                ;;
index 7f500d9..faa82ec 100755 (executable)
@@ -32,6 +32,7 @@ platform_check_image() {
        rt-n15 | \
        rt-n56u | \
        sl-r7205 | \
+       w306r-v20 |\
        w502u |\
        wr6202 |\
        v22rw-2x2 | \
index c2ec146..08b04f9 100644 (file)
@@ -45,6 +45,7 @@ enum ramips_mach_type {
        RAMIPS_MACH_PWH2004,            /* Prolink 2004H / Abocom 5205 */
        RAMIPS_MACH_SL_R7205,           /* Skylink SL-R7205 Wireless 3G Router*/
        RAMIPS_MACH_V22RW_2X2,          /* Ralink AP-RT3052-V22RW-2X2 */
+       RAMIPS_MACH_W306R_V20,          /* Tenda W306R_V20 */
        RAMIPS_MACH_W502U,              /* ALFA Networks W502U */
        RAMIPS_MACH_WCR150GN,           /* Sparklan WCR-150GN */
        RAMIPS_MACH_WHR_G300N,          /* Buffalo WHR-G300N */
index ef4ddf4..b9850a6 100644 (file)
@@ -104,6 +104,11 @@ config RT305X_MACH_V22RW_2X2
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_W306R_V20
+       bool "Tenda W306R V2.0 board support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_WL341V3
        bool "Sitecom WL-341 v3 board support"
        select RALINK_DEV_GPIO_BUTTONS
index 0336936..f5c6aa8 100644 (file)
@@ -29,6 +29,7 @@ obj-$(CONFIG_RT305X_MACH_RT_G32_REVB) += mach-rt-g32-revb.o
 obj-$(CONFIG_RT305X_MACH_RT_N10_PLUS)  += mach-rt-n10-plus.o
 obj-$(CONFIG_RT305X_MACH_SL_R7205)     += mach-sl-r7205.o
 obj-$(CONFIG_RT305X_MACH_V22RW_2X2)    += mach-v22rw-2x2.o
+obj-$(CONFIG_RT305X_MACH_W306R_V20)    += mach-w306r-v20.o
 obj-$(CONFIG_RT305X_MACH_W502U)                += mach-w502u.o
 obj-$(CONFIG_RT305X_MACH_WCR150GN)     += mach-wcr150gn.o
 obj-$(CONFIG_RT305X_MACH_WHR_G300N)    += mach-whr-g300n.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-w306r-v20.c
new file mode 100644 (file)
index 0000000..6235a73
--- /dev/null
@@ -0,0 +1,72 @@
+/*
+ *  Tenda W306R V2.0 board support
+ *
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/ethtool.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+#include <asm/mach-ralink/ramips_eth_platform.h>
+
+#include "devices.h"
+
+#define W306R_V20_GPIO_LED_SYS         9 /* FIXME */
+#define W306R_V20_GPIO_LED_WPS         13
+
+#define W306R_V20_GPIO_BUTTON_RESET    10
+
+#define W306R_V20_KEYS_POLL_INTERVAL   20
+#define W306R_V20_KEYS_DEBOUNCE_INTERVAL (3 * W306R_V20_KEYS_POLL_INTERVAL)
+
+static struct gpio_led w306r_v20_leds_gpio[] __initdata = {
+       {
+               .name           = "w306r-v20:green:sys",
+               .gpio           = W306R_V20_GPIO_LED_SYS,
+               .active_low     = 1,
+       }, {
+               .name           = "w306r-v20:green:wps",
+               .gpio           = W306R_V20_GPIO_LED_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_keys_button w306r_v20_gpio_buttons[] __initdata = {
+       {
+               .desc           = "RESET/WPS",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = W306R_V20_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = W306R_V20_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }
+};
+
+static void __init w306r_v20_init(void)
+{
+       rt305x_register_flash(0);
+
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_LLLLW;
+       rt305x_register_ethernet();
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(w306r_v20_leds_gpio),
+                                 w306r_v20_leds_gpio);
+       ramips_register_gpio_buttons(-1, W306R_V20_KEYS_POLL_INTERVAL,
+                                    ARRAY_SIZE(w306r_v20_gpio_buttons),
+                                    w306r_v20_gpio_buttons);
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_W306R_V20, "W306R_V20", "Tenda W306R V2.0",
+            w306r_v20_init);
index 0c37f7e..aac9ad2 100644 (file)
@@ -371,6 +371,10 @@ define Image/Build/Profile/V22RW2X2
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,v22rw-2x2,V22RW-2X2,ttyS1,57600,phys)
 endef
 
+define Image/Build/Profile/W306R_V20
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,w306r-v20,W306R_V20,ttyS1,57600,phys)
+endef
+
 define Image/Build/Profile/W502U
        $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_8M,w502u,W502U,ttyS1,115200,phys)
 endef
@@ -428,6 +432,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/SLR7205,$(1))
        $(call Image/Build/Profile/V22RW2X2,$(1))
+       $(call Image/Build/Profile/W306R_V20,$(1))
        $(call Image/Build/Profile/W502U,$(1))
        $(call Image/Build/Profile/WCR150GN,$(1))
        $(call Image/Build/Profile/WHRG300N,$(1))
index c814638..5f3a214 100644 (file)
@@ -111,6 +111,7 @@ CONFIG_RT305X_MACH_RT_G32_REVB=y
 CONFIG_RT305X_MACH_RT_N10_PLUS=y
 CONFIG_RT305X_MACH_SL_R7205=y
 CONFIG_RT305X_MACH_V22RW_2X2=y
+CONFIG_RT305X_MACH_W306R_V20=y
 CONFIG_RT305X_MACH_W502U=y
 CONFIG_RT305X_MACH_WCR150GN=y
 CONFIG_RT305X_MACH_WHR_G300N=y
diff --git a/target/linux/ramips/rt305x/profiles/tenda.mk b/target/linux/ramips/rt305x/profiles/tenda.mk
new file mode 100644 (file)
index 0000000..5e45b5f
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/W306R_V20
+       NAME:=Tenda W306R V2.0
+       PACKAGES:=
+endef
+
+define Profile/W306R_V20/Description
+       Package set for Tenda W306R V2.0 board
+endef
+
+$(eval $(call Profile,W306R_V20))