tools/flex: update to 2.6.1
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Mar 2016 09:26:51 +0000 (09:26 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 16 Mar 2016 09:26:51 +0000 (09:26 +0000)
Update flex to 2.6.1
* Flex has moved to Github, adjust download link
* Remove patch that has been applied upstream
* Disable building tests to avoid circular dependency to bison
  - disable also docs and examples at the same time

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49025 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/flex/Makefile
tools/flex/patches/100-disable-tests-docs.patch [new file with mode: 0644]
tools/flex/patches/100-remove_no_undefined.patch [deleted file]

index 0e56ede..78eb1e0 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2008-2014 OpenWrt.org
+# Copyright (C) 2008-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,12 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=flex
-PKG_VERSION:=2.5.39
+PKG_VERSION:=2.6.1
 
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=77d44c6bb8c0705e0017ab9a84a1502b
-PKG_CAT:=bzcat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://github.com/westes/flex/releases/download/v$(PKG_VERSION)/
+PKG_MD5SUM:=cd3c86290fc2676a641aefafeb10848a
 
 HOST_BUILD_PARALLEL:=1
 
 
 HOST_BUILD_PARALLEL:=1
 
diff --git a/tools/flex/patches/100-disable-tests-docs.patch b/tools/flex/patches/100-disable-tests-docs.patch
new file mode 100644 (file)
index 0000000..d6e289d
--- /dev/null
@@ -0,0 +1,13 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -45,10 +45,7 @@
+ SUBDIRS = \
+       lib \
+       src \
+-      doc \
+-      examples \
+       po \
+-      tests \
+       tools
+ # Create the ChangeLog, but only if we're inside a git working directory
diff --git a/tools/flex/patches/100-remove_no_undefined.patch b/tools/flex/patches/100-remove_no_undefined.patch
deleted file mode 100644 (file)
index 4e8aca1..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -73,13 +73,13 @@ libfl_la_SOURCES = \
-       libmain.c \
-       libyywrap.c
--libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
-+libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
- libfl_pic_la_SOURCES = \
-       libmain.c \
-       libyywrap.c
--libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
-+libfl_pic_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
- noinst_HEADERS = \
-       flexdef.h \