package/kernel: move block2mtd to block.mk
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 24 Apr 2010 13:45:05 +0000 (13:45 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 24 Apr 2010 13:45:05 +0000 (13:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21134 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/block.mk
package/kernel/modules/other.mk

index ebd5d4d..f107425 100644 (file)
@@ -161,6 +161,16 @@ endef
 $(eval $(call KernelPackage,ata-via-sata))
 
 
+define KernelPackage/block2mtd
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Block device MTD emulation
+  KCONFIG:=CONFIG_MTD_BLOCK2MTD
+  FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
+endef
+
+$(eval $(call KernelPackage,block2mtd))
+
+
 define KernelPackage/dm
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Device Mapper
index 177318d..10db180 100644 (file)
@@ -7,14 +7,6 @@
 
 OTHER_MENU:=Other modules
 
-define KernelPackage/block2mtd
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Block device MTD emulation
-  KCONFIG:=CONFIG_MTD_BLOCK2MTD
-  FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
-endef
-$(eval $(call KernelPackage,block2mtd))
-
 define KernelPackage/crc-itu-t
   SUBMENU:=$(OTHER_MENU)
   TITLE:=CRC ITU-T V.41 support