mac80211: enable support for RaLink Rt53xx USB devices in rt2800usb
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jan 2012 07:44:46 +0000 (07:44 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 25 Jan 2012 07:44:46 +0000 (07:44 +0000)
Hi!

On Mon, Nov 14, 2011 at 03:01:34PM +0100, Daniel Golle wrote:
> The driver works quite nice and stable for me using a RaLink Rt5370 USB device.
>
> Signed-off-by: Daniel Golle <dgolle@allnet.de>
>
> Index: package/mac80211/Makefile
> ===================================================================
> --- package/mac80211/Makefile (revision 29114)
> +++ package/mac80211/Makefile (working copy)
> @@ -1147,6 +1147,7 @@
>   CONFIG_RT2800_LIB=$(if $(CONFIG_PACKAGE_kmod-rt2800-lib),m) \
>   CONFIG_RT2800PCI=$(if $(CONFIG_PACKAGE_kmod-rt2800-pci),m) \
>   CONFIG_RT2800USB=$(if $(CONFIG_PACKAGE_kmod-rt2800-usb),m) \
> + CONFIG_RT2800USB_RT53XX=$(if $(CONFIG_PACKAGE_kmod-rt2800-usb),y) \
>   CONFIG_RTL8180=$(if $(CONFIG_PACKAGE_kmod-rtl8180),m) \
>   CONFIG_RTL8187=$(if $(CONFIG_PACKAGE_kmod-rtl8187),m) \
>   CONFIG_RTL8192CE= \

Aparently this was wrong, CONFIG_RT2800USB_RT53XX is supposed to live in
BUILDARGS rather than MAKE_OPTS to actually get support for the Rt5370.
Thanks to actmnophn for the hint!

This reverts changeset 29116 and adds it to the right section in the Makefile.

Signed-off-by: Daniel Golle <dgolle@allnet.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29906 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile

index ae52f7d..14e8579 100644 (file)
@@ -1111,6 +1111,7 @@ BUILDFLAGS:= \
        $(if $(NEED_RT2X00_LIB_LEDS),-DCONFIG_RT2X00_LIB_LEDS) \
        $(if $(CONFIG_PACKAGE_kmod-rt2x00-pci),-DCONFIG_RT2X00_LIB_PCI) \
        $(if $(CONFIG_PACKAGE_kmod-rt2x00-usb),-DCONFIG_RT2X00_LIB_USB) \
+       $(if $(CONFIG_PACKAGE_kmod-rt2x00-usb),-DCONFIG_RT2800USB_RT53XX) \
        $(if $(CONFIG_PACKAGE_kmod-rt2x00-soc),-DCONFIG_RT2X00_LIB_SOC) \
        $(if $(CONFIG_TARGET_atheros),-DCONFIG_ATH5K_AHB,-DCONFIG_ATH5K_PCI) \
        $(if $(CONFIG_PACKAGE_kmod-iwl3945),-DCONFIG_IWL3945) \
@@ -1188,7 +1189,6 @@ MAKE_OPTS:= \
        CONFIG_RT2800_LIB=$(if $(CONFIG_PACKAGE_kmod-rt2800-lib),m) \
        CONFIG_RT2800PCI=$(if $(CONFIG_PACKAGE_kmod-rt2800-pci),m) \
        CONFIG_RT2800USB=$(if $(CONFIG_PACKAGE_kmod-rt2800-usb),m) \
-       CONFIG_RT2800USB_RT53XX=$(if $(CONFIG_PACKAGE_kmod-rt2800-usb),y) \
        CONFIG_RTL8180=$(if $(CONFIG_PACKAGE_kmod-rtl8180),m) \
        CONFIG_RTL8187=$(if $(CONFIG_PACKAGE_kmod-rtl8187),m) \
        CONFIG_RTL8192CE= \