ar71xx: Add support for wdr7500v3
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Nov 2015 10:17:15 +0000 (10:17 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Nov 2015 10:17:15 +0000 (10:17 +0000)
The device is similar to Archer C7 v2, but with 8M of flash, and 6 external
antennas.  Reason for breaking the naming pattern is that sticker on the back
mentions "WDR7500" and has no mention of "Archer".

Signed-off-by: Srdjan Rosic <rosic@google.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47344 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index ddc0fc1..7bf2f27 100644 (file)
@@ -372,7 +372,14 @@ define Device/archer-c7-v2
     DEVICE_PROFILE := ARCHERC7
     TPLINK_HWID := 0xc7000002
 endef
-TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2
+
+define Device/tl-wdr7500-v3
+    $(Device/tplink-8mlzma)
+    BOARDNAME := ARCHER-C7
+    DEVICE_PROFILE := ARCHERC7
+    TPLINK_HWID := 0x75000003
+endef
+TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
 
 define Device/antminer-s1
     $(Device/tplink-8mlzma)