explicitly set CONFIG_SHELL to bash for the kernel headers configure
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 17:14:42 +0000 (17:14 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 17:14:42 +0000 (17:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5025 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/kernel-headers/Makefile

index a893b85..a242ea2 100644 (file)
@@ -48,7 +48,10 @@ endef
 
 define Build/Configure
        -$(CP) ./files/config.$(LINUX_KARCH) $(PKG_BUILD_DIR)/.config
-       $(MAKE) -C $(PKG_BUILD_DIR) ARCH=$(LINUX_KARCH) oldconfig include/linux/version.h
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               ARCH=$(LINUX_KARCH) \
+               CONFIG_SHELL=$(shell which bash) \
+               oldconfig include/linux/version.h
 endef
 
 define Build/Compile