kernel: update kernel 4.3-rc7 to version 4.3
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Nov 2015 22:28:40 +0000 (22:28 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 4 Nov 2015 22:28:40 +0000 (22:28 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47384 3c298f89-4303-0410-b956-a3cf2f4a3e73

19 files changed:
include/kernel-version.mk
target/linux/generic/config-4.3
target/linux/generic/patches-4.3/204-module_strip.patch
target/linux/generic/patches-4.3/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-4.3/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/patches-4.3/720-phy_adm6996.patch
target/linux/generic/patches-4.3/721-phy_packets.patch
target/linux/generic/patches-4.3/722-phy_mvswitch.patch
target/linux/generic/patches-4.3/723-phy_ip175c.patch
target/linux/generic/patches-4.3/724-phy_ar8216.patch
target/linux/generic/patches-4.3/725-phy_rtl8306.patch
target/linux/generic/patches-4.3/726-phy_rtl8366.patch
target/linux/generic/patches-4.3/727-phy-rtl8367.patch
target/linux/generic/patches-4.3/728-phy-rtl8367b.patch
target/linux/generic/patches-4.3/729-phy-tantos.patch
target/linux/generic/patches-4.3/730-phy_b53.patch
target/linux/generic/patches-4.3/732-phy-ar8216-led-support.patch
target/linux/generic/patches-4.3/733-phy_mvsw61xx.patch
target/linux/generic/patches-4.3/863-gpiommc.patch

index 1ecb37c..3955a29 100644 (file)
@@ -5,12 +5,12 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.18 = .23
 LINUX_VERSION-4.0 = .9
 LINUX_VERSION-4.1 = .11
 LINUX_VERSION-3.18 = .23
 LINUX_VERSION-4.0 = .9
 LINUX_VERSION-4.1 = .11
-LINUX_VERSION-4.3 = -rc7
+LINUX_VERSION-4.3 =
 
 LINUX_KERNEL_MD5SUM-3.18.23 = dc6d265ab38716be3676ac294b481ad8
 LINUX_KERNEL_MD5SUM-4.0.9 = 40fc5f6e2d718e539b45e6601c71985b
 LINUX_KERNEL_MD5SUM-4.1.11 = 63e5981e38f935772a5309289fe76972
 
 LINUX_KERNEL_MD5SUM-3.18.23 = dc6d265ab38716be3676ac294b481ad8
 LINUX_KERNEL_MD5SUM-4.0.9 = 40fc5f6e2d718e539b45e6601c71985b
 LINUX_KERNEL_MD5SUM-4.1.11 = 63e5981e38f935772a5309289fe76972
-LINUX_KERNEL_MD5SUM-4.3-rc7 = b33f9c9c1a597bb8e0d6f84c074e733f
+LINUX_KERNEL_MD5SUM-4.3 = 58b35794eee3b6d52ce7be39357801e7
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index f72c169..eb8a648 100644 (file)
@@ -978,6 +978,7 @@ CONFIG_DISABLE_DEV_COREDUMP=y
 # CONFIG_DNOTIFY is not set
 # CONFIG_DNS_RESOLVER is not set
 CONFIG_DOUBLEFAULT=y
 # CONFIG_DNOTIFY is not set
 # CONFIG_DNS_RESOLVER is not set
 CONFIG_DOUBLEFAULT=y
+# CONFIG_DP83848_PHY is not set
 # CONFIG_DP83867_PHY is not set
 CONFIG_DQL=y
 # CONFIG_DRAGONRISE_FF is not set
 # CONFIG_DP83867_PHY is not set
 CONFIG_DQL=y
 # CONFIG_DRAGONRISE_FF is not set
@@ -2022,6 +2023,7 @@ CONFIG_LZMA_DECOMPRESS=y
 # CONFIG_M25PXX_PREFER_SMALL_SECTOR_ERASE is not set
 # CONFIG_M62332 is not set
 # CONFIG_MAC80211 is not set
 # CONFIG_M25PXX_PREFER_SMALL_SECTOR_ERASE is not set
 # CONFIG_M62332 is not set
 # CONFIG_MAC80211 is not set
+CONFIG_MAC80211_STA_HASH_MAX_SIZE=0
 # CONFIG_MAC80211_MESSAGE_TRACING is not set
 # CONFIG_MACB is not set
 # CONFIG_MACH_ASM9260 is not set
 # CONFIG_MAC80211_MESSAGE_TRACING is not set
 # CONFIG_MACB is not set
 # CONFIG_MACH_ASM9260 is not set
@@ -2973,6 +2975,7 @@ CONFIG_PARTITION_ADVANCED=y
 # CONFIG_PCIEASPM is not set
 # CONFIG_PCIEPORTBUS is not set
 # CONFIG_PCIE_ECRC is not set
 # CONFIG_PCIEASPM is not set
 # CONFIG_PCIEPORTBUS is not set
 # CONFIG_PCIE_ECRC is not set
+# CONFIG_PCIE_IPROC is not set
 # CONFIG_PCIPCWATCHDOG is not set
 # CONFIG_PCI_ATMEL is not set
 # CONFIG_PCI_CNB20LE_QUIRK is not set
 # CONFIG_PCIPCWATCHDOG is not set
 # CONFIG_PCI_ATMEL is not set
 # CONFIG_PCI_CNB20LE_QUIRK is not set
@@ -3228,6 +3231,7 @@ CONFIG_RCU_TORTURE_TEST_SLOW_INIT_DELAY=3
 # CONFIG_REGULATOR_MAX8660 is not set
 # CONFIG_REGULATOR_MAX8952 is not set
 # CONFIG_REGULATOR_MAX8973 is not set
 # CONFIG_REGULATOR_MAX8660 is not set
 # CONFIG_REGULATOR_MAX8952 is not set
 # CONFIG_REGULATOR_MAX8973 is not set
+# CONFIG_REGULATOR_MT6311 is not set
 # CONFIG_REGULATOR_PFUZE100 is not set
 # CONFIG_REGULATOR_PWM is not set
 # CONFIG_REGULATOR_TI_ABB is not set
 # CONFIG_REGULATOR_PFUZE100 is not set
 # CONFIG_REGULATOR_PWM is not set
 # CONFIG_REGULATOR_TI_ABB is not set
@@ -4124,6 +4128,7 @@ CONFIG_SYSFS=y
 # CONFIG_SYSFS_DEPRECATED_V2 is not set
 # CONFIG_SYSFS_SYSCALL is not set
 # CONFIG_SYSTEMPORT is not set
 # CONFIG_SYSFS_DEPRECATED_V2 is not set
 # CONFIG_SYSFS_SYSCALL is not set
 # CONFIG_SYSTEMPORT is not set
+# CONFIG_SYSTEM_DATA_VERIFICATION is not set
 # CONFIG_SYSTEM_TRUSTED_KEYRING is not set
 # CONFIG_SYSV68_PARTITION is not set
 CONFIG_SYSVIPC=y
 # CONFIG_SYSTEM_TRUSTED_KEYRING is not set
 # CONFIG_SYSV68_PARTITION is not set
 CONFIG_SYSVIPC=y
@@ -4300,6 +4305,7 @@ CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
 # CONFIG_UFS_FS is not set
 # CONFIG_UHID is not set
 CONFIG_UIDGID_STRICT_TYPE_CHECKS=y
 # CONFIG_UFS_FS is not set
 # CONFIG_UHID is not set
 CONFIG_UIDGID_STRICT_TYPE_CHECKS=y
+CONFIG_UID16=y
 # CONFIG_UIO is not set
 # CONFIG_ULTRA is not set
 # CONFIG_ULTRIX_PARTITION is not set
 # CONFIG_UIO is not set
 # CONFIG_ULTRA is not set
 # CONFIG_ULTRIX_PARTITION is not set
index 4080ee6..32f979a 100644 (file)
@@ -109,7 +109,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -2836,6 +2836,7 @@ static struct module *setup_load_info(st
+@@ -2840,6 +2840,7 @@ static struct module *setup_load_info(st
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -117,7 +117,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        const char *modmagic = get_modinfo(info, "vermagic");
        int err;
  
        const char *modmagic = get_modinfo(info, "vermagic");
        int err;
  
-@@ -2861,6 +2862,7 @@ static int check_modinfo(struct module *
+@@ -2865,6 +2866,7 @@ static int check_modinfo(struct module *
                pr_warn("%s: module is from the staging directory, the quality "
                        "is unknown, you have been warned.\n", mod->name);
        }
                pr_warn("%s: module is from the staging directory, the quality "
                        "is unknown, you have been warned.\n", mod->name);
        }
index d2e1465..7ae6abf 100644 (file)
@@ -88,7 +88,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
        default:
 --- a/net/ipv6/fib6_rules.c
 +++ b/net/ipv6/fib6_rules.c
        default:
 --- a/net/ipv6/fib6_rules.c
 +++ b/net/ipv6/fib6_rules.c
-@@ -73,6 +73,10 @@ static int fib6_rule_action(struct fib_r
+@@ -84,6 +84,10 @@ static int fib6_rule_action(struct fib_r
                err = -EACCES;
                rt = net->ipv6.ip6_prohibit_entry;
                goto discard_pkt;
                err = -EACCES;
                rt = net->ipv6.ip6_prohibit_entry;
                goto discard_pkt;
@@ -143,7 +143,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  static const struct rt6_info ip6_blk_hole_entry_template = {
        .dst = {
                .__refcnt       = ATOMIC_INIT(1),
  static const struct rt6_info ip6_blk_hole_entry_template = {
        .dst = {
                .__refcnt       = ATOMIC_INIT(1),
-@@ -1881,6 +1898,11 @@ int ip6_route_info_create(struct fib6_co
+@@ -1886,6 +1903,11 @@ int ip6_route_info_create(struct fib6_co
                        rt->dst.output = ip6_pkt_prohibit_out;
                        rt->dst.input = ip6_pkt_prohibit;
                        break;
                        rt->dst.output = ip6_pkt_prohibit_out;
                        rt->dst.input = ip6_pkt_prohibit;
                        break;
@@ -155,7 +155,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                case RTN_THROW:
                case RTN_UNREACHABLE:
                default:
                case RTN_THROW:
                case RTN_UNREACHABLE:
                default:
-@@ -2483,6 +2505,17 @@ static int ip6_pkt_prohibit_out(struct s
+@@ -2488,6 +2510,17 @@ static int ip6_pkt_prohibit_out(struct s
        return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
  }
  
        return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
  }
  
@@ -173,7 +173,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  /*
   *    Allocate a dst for local (unicast / anycast) address.
   */
  /*
   *    Allocate a dst for local (unicast / anycast) address.
   */
-@@ -2723,7 +2756,8 @@ static int rtm_to_fib6_config(struct sk_
+@@ -2728,7 +2761,8 @@ static int rtm_to_fib6_config(struct sk_
        if (rtm->rtm_type == RTN_UNREACHABLE ||
            rtm->rtm_type == RTN_BLACKHOLE ||
            rtm->rtm_type == RTN_PROHIBIT ||
        if (rtm->rtm_type == RTN_UNREACHABLE ||
            rtm->rtm_type == RTN_BLACKHOLE ||
            rtm->rtm_type == RTN_PROHIBIT ||
@@ -183,7 +183,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -3079,6 +3113,9 @@ static int rt6_fill_node(struct net *net
+@@ -3084,6 +3118,9 @@ static int rt6_fill_node(struct net *net
                case -EACCES:
                        rtm->rtm_type = RTN_PROHIBIT;
                        break;
                case -EACCES:
                        rtm->rtm_type = RTN_PROHIBIT;
                        break;
@@ -193,7 +193,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                case -EAGAIN:
                        rtm->rtm_type = RTN_THROW;
                        break;
                case -EAGAIN:
                        rtm->rtm_type = RTN_THROW;
                        break;
-@@ -3347,6 +3384,8 @@ static int ip6_route_dev_notify(struct n
+@@ -3352,6 +3389,8 @@ static int ip6_route_dev_notify(struct n
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                net->ipv6.ip6_prohibit_entry->dst.dev = dev;
                net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                net->ipv6.ip6_prohibit_entry->dst.dev = dev;
                net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -202,7 +202,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -3563,6 +3602,17 @@ static int __net_init ip6_route_net_init
+@@ -3568,6 +3607,17 @@ static int __net_init ip6_route_net_init
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
@@ -220,7 +220,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
-@@ -3581,6 +3631,8 @@ out:
+@@ -3586,6 +3636,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -229,7 +229,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -3598,6 +3650,7 @@ static void __net_exit ip6_route_net_exi
+@@ -3603,6 +3655,7 @@ static void __net_exit ip6_route_net_exi
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
@@ -237,7 +237,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
-@@ -3695,6 +3748,9 @@ int __init ip6_route_init(void)
+@@ -3700,6 +3753,9 @@ int __init ip6_route_init(void)
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
index 1d86e2f..c6734e0 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
 
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
 
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -4158,6 +4158,9 @@ static enum gro_result dev_gro_receive(s
+@@ -4185,6 +4185,9 @@ static enum gro_result dev_gro_receive(s
        enum gro_result ret;
        int grow;
  
        enum gro_result ret;
        int grow;
  
@@ -27,7 +27,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        if (!(skb->dev->features & NETIF_F_GRO))
                goto normal;
  
        if (!(skb->dev->features & NETIF_F_GRO))
                goto normal;
  
-@@ -5309,6 +5312,48 @@ static void __netdev_adjacent_dev_unlink
+@@ -5336,6 +5339,48 @@ static void __netdev_adjacent_dev_unlink
                                           &upper_dev->adj_list.lower);
  }
  
                                           &upper_dev->adj_list.lower);
  }
  
@@ -76,7 +76,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *private)
  static int __netdev_upper_dev_link(struct net_device *dev,
                                   struct net_device *upper_dev, bool master,
                                   void *private)
-@@ -5374,6 +5419,7 @@ static int __netdev_upper_dev_link(struc
+@@ -5401,6 +5446,7 @@ static int __netdev_upper_dev_link(struc
                        goto rollback_lower_mesh;
        }
  
                        goto rollback_lower_mesh;
        }
  
@@ -84,7 +84,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
        return 0;
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
        return 0;
-@@ -5497,6 +5543,7 @@ void netdev_upper_dev_unlink(struct net_
+@@ -5524,6 +5570,7 @@ void netdev_upper_dev_unlink(struct net_
        list_for_each_entry(i, &upper_dev->all_adj_list.upper, list)
                __netdev_adjacent_dev_unlink(dev, i->dev);
  
        list_for_each_entry(i, &upper_dev->all_adj_list.upper, list)
                __netdev_adjacent_dev_unlink(dev, i->dev);
  
@@ -92,7 +92,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
        call_netdevice_notifiers_info(NETDEV_CHANGEUPPER, dev,
                                      &changeupper_info.info);
  }
-@@ -6037,6 +6084,7 @@ int dev_set_mac_address(struct net_devic
+@@ -6064,6 +6111,7 @@ int dev_set_mac_address(struct net_devic
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
        if (err)
                return err;
        dev->addr_assign_type = NET_ADDR_SET;
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        return 0;
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
        return 0;
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1623,6 +1623,8 @@ struct net_device {
+@@ -1629,6 +1629,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
index 1c32b76..fa716d0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -146,6 +146,13 @@ config MICROCHIP_PHY
+@@ -151,6 +151,13 @@ config MICROCHIP_PHY
        help
          Supports the LAN88XX PHYs.
  
        help
          Supports the LAN88XX PHYs.
  
index e83eadb..b7e04ab 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1286,6 +1286,7 @@ enum netdev_priv_flags {
+@@ -1292,6 +1292,7 @@ enum netdev_priv_flags {
        IFF_VRF_MASTER                  = 1<<20,
        IFF_NO_QUEUE                    = 1<<21,
        IFF_OPENVSWITCH                 = 1<<22,
        IFF_VRF_MASTER                  = 1<<20,
        IFF_NO_QUEUE                    = 1<<21,
        IFF_OPENVSWITCH                 = 1<<22,
@@ -8,7 +8,7 @@
  };
  
  #define IFF_802_1Q_VLAN                       IFF_802_1Q_VLAN
  };
  
  #define IFF_802_1Q_VLAN                       IFF_802_1Q_VLAN
-@@ -1311,6 +1312,7 @@ enum netdev_priv_flags {
+@@ -1317,6 +1318,7 @@ enum netdev_priv_flags {
  #define IFF_VRF_MASTER                        IFF_VRF_MASTER
  #define IFF_NO_QUEUE                  IFF_NO_QUEUE
  #define IFF_OPENVSWITCH                       IFF_OPENVSWITCH
  #define IFF_VRF_MASTER                        IFF_VRF_MASTER
  #define IFF_NO_QUEUE                  IFF_NO_QUEUE
  #define IFF_OPENVSWITCH                       IFF_OPENVSWITCH
@@ -16,7 +16,7 @@
  
  /**
   *    struct net_device - The DEVICE structure.
  
  /**
   *    struct net_device - The DEVICE structure.
-@@ -1588,6 +1590,11 @@ struct net_device {
+@@ -1594,6 +1596,11 @@ struct net_device {
        const struct switchdev_ops *switchdev_ops;
  #endif
  
        const struct switchdev_ops *switchdev_ops;
  #endif
  
@@ -28,7 +28,7 @@
        const struct header_ops *header_ops;
  
        unsigned int            flags;
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1655,6 +1662,10 @@ struct net_device {
+@@ -1661,6 +1668,10 @@ struct net_device {
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
@@ -86,7 +86,7 @@
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
        help
 --- a/net/core/dev.c
 +++ b/net/core/dev.c
-@@ -2678,10 +2678,20 @@ static int xmit_one(struct sk_buff *skb,
+@@ -2705,10 +2705,20 @@ static int xmit_one(struct sk_buff *skb,
        if (!list_empty(&ptype_all) || !list_empty(&dev->ptype_all))
                dev_queue_xmit_nit(skb, dev);
  
        if (!list_empty(&ptype_all) || !list_empty(&dev->ptype_all))
                dev_queue_xmit_nit(skb, dev);
  
index 2d366bf..2ecae24 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -153,6 +153,10 @@ config ADM6996_PHY
+@@ -158,6 +158,10 @@ config ADM6996_PHY
          Currently supports the ADM6996FC and ADM6996M switches.
          Support for FC is very limited.
  
          Currently supports the ADM6996FC and ADM6996M switches.
          Support for FC is very limited.
  
index e5c9bce..4b711a2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -157,6 +157,10 @@ config MVSWITCH_PHY
+@@ -162,6 +162,10 @@ config MVSWITCH_PHY
        tristate "Driver for Marvell 88E6060 switches"
        select ETHERNET_PACKET_MANGLE
  
        tristate "Driver for Marvell 88E6060 switches"
        select ETHERNET_PACKET_MANGLE
  
index de94037..9b1f3d1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -161,6 +161,11 @@ config IP17XX_PHY
+@@ -166,6 +166,11 @@ config IP17XX_PHY
        tristate "Driver for IC+ IP17xx switches"
        select SWCONFIG
  
        tristate "Driver for IC+ IP17xx switches"
        select SWCONFIG
  
index 803e770..5ce2272 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -166,6 +166,10 @@ config AR8216_PHY
+@@ -171,6 +171,10 @@ config AR8216_PHY
        select ETHERNET_PACKET_MANGLE
        select SWCONFIG
  
        select ETHERNET_PACKET_MANGLE
        select SWCONFIG
  
index bba83b3..2547f66 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -261,6 +261,31 @@ config MDIO_BCM_UNIMAC
+@@ -266,6 +266,31 @@ config MDIO_BCM_UNIMAC
          This hardware can be found in the Broadcom GENET Ethernet MAC
          controllers as well as some Broadcom Ethernet switches such as the
          Starfighter 2 switches.
          This hardware can be found in the Broadcom GENET Ethernet MAC
          controllers as well as some Broadcom Ethernet switches such as the
          Starfighter 2 switches.
index a10856f..d78c68d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -284,6 +284,10 @@ config RTL8366RB_PHY
+@@ -289,6 +289,10 @@ config RTL8366RB_PHY
        tristate "Driver for the Realtek RTL8366RB switch"
        select SWCONFIG
  
        tristate "Driver for the Realtek RTL8366RB switch"
        select SWCONFIG
  
index 881be7d..5c329f6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -288,6 +288,10 @@ config RTL8367_PHY
+@@ -293,6 +293,10 @@ config RTL8367_PHY
        tristate "Driver for the Realtek RTL8367R/M switches"
        select SWCONFIG
  
        tristate "Driver for the Realtek RTL8367R/M switches"
        select SWCONFIG
  
index 19ea8b0..12ae990 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -299,3 +299,8 @@ endif # PHYLIB
+@@ -304,3 +304,8 @@ endif # PHYLIB
  config MICREL_KS8995MA
        tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
        depends on SPI
  config MICREL_KS8995MA
        tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
        depends on SPI
index 648919f..83a6460 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -294,6 +294,8 @@ config RTL8367B_PHY
+@@ -299,6 +299,8 @@ config RTL8367B_PHY
  
  endif # RTL8366_SMI
  
  
  endif # RTL8366_SMI
  
index 7567f66..3791269 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -166,6 +166,10 @@ config AR8216_PHY
+@@ -171,6 +171,10 @@ config AR8216_PHY
        select ETHERNET_PACKET_MANGLE
        select SWCONFIG
  
        select ETHERNET_PACKET_MANGLE
        select SWCONFIG
  
index 9f7274c..2b315a7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
 --- a/drivers/net/phy/Kconfig
 +++ b/drivers/net/phy/Kconfig
-@@ -157,6 +157,10 @@ config MVSWITCH_PHY
+@@ -162,6 +162,10 @@ config MVSWITCH_PHY
        tristate "Driver for Marvell 88E6060 switches"
        select ETHERNET_PACKET_MANGLE
  
        tristate "Driver for Marvell 88E6060 switches"
        select ETHERNET_PACKET_MANGLE
  
index 8f786b9..27115a0 100644 (file)
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
 +be done automatically.
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -4792,6 +4792,11 @@ T:      git git://linuxtv.org/anttip/media_tr
+@@ -4800,6 +4800,11 @@ T:      git git://linuxtv.org/anttip/media_tr
  S:    Maintained
  F:    drivers/media/usb/hackrf/
  
  S:    Maintained
  F:    drivers/media/usb/hackrf/