Netgear WG302 v2 / WAG302 v2 support
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Apr 2007 14:43:33 +0000 (14:43 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Apr 2007 14:43:33 +0000 (14:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6830 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ixp4xx-2.6/config/default
target/linux/ixp4xx-2.6/patches/300-wg302v2.patch [new file with mode: 0644]
target/linux/ixp4xx-2.6/patches/310-wg302v2_setup_mac.patch [new file with mode: 0644]

index eceddf9..3e3cb55 100644 (file)
@@ -18,8 +18,6 @@ CONFIG_ARCH_AVILA=y
 # CONFIG_ARCH_INTEGRATOR is not set
 # CONFIG_ARCH_IOP32X is not set
 # CONFIG_ARCH_IOP33X is not set
-CONFIG_MACH_PRONGHORN=y
-CONFIG_MACH_PRONGHORNMETRO=y
 CONFIG_ARCH_IXDP425=y
 CONFIG_ARCH_IXDP4XX=y
 # CONFIG_ARCH_IXP2000 is not set
@@ -221,6 +219,9 @@ CONFIG_MACH_GATEWAY7001=y
 # CONFIG_MACH_IXDPG425 is not set
 CONFIG_MACH_NAS100D=y
 CONFIG_MACH_NSLU2=y
+CONFIG_MACH_PRONGHORN=y
+CONFIG_MACH_PRONGHORNMETRO=y
+CONFIG_MACH_WG302V2=y
 # CONFIG_MAC_PARTITION is not set
 # CONFIG_MINIX_FS is not set
 CONFIG_MINI_FO=y
diff --git a/target/linux/ixp4xx-2.6/patches/300-wg302v2.patch b/target/linux/ixp4xx-2.6/patches/300-wg302v2.patch
new file mode 100644 (file)
index 0000000..fc3de40
--- /dev/null
@@ -0,0 +1,231 @@
+diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/Kconfig linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Kconfig
+--- linux-2.6.19.2/arch/arm/mach-ixp4xx/Kconfig        2007-04-02 16:09:06.000000000 +0200
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Kconfig   2007-04-02 16:01:25.000000000 +0200
+@@ -41,6 +41,14 @@
+         7001 Access Point. For more information on this platform,
+         see http://openwrt.org
++config MACH_WG302V2
++      bool "Netgear WG302 v2 / WAG302 v2"
++      select PCI
++      help
++        Say 'Y' here if you want your kernel to support Netgear's 
++        WG302 v2 or WAG302 v2 Access Points. For more information
++        on this platform, see http://openwrt.org
++
+ config ARCH_IXDP425
+       bool "IXDP425"
+       help
+diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/Makefile linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Makefile
+--- linux-2.6.19.2/arch/arm/mach-ixp4xx/Makefile       2007-04-02 16:09:06.000000000 +0200
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/Makefile  2007-04-02 16:09:25.000000000 +0200
+@@ -12,6 +12,7 @@
+ obj-pci-$(CONFIG_MACH_NSLU2)          += nslu2-pci.o
+ obj-pci-$(CONFIG_MACH_NAS100D)                += nas100d-pci.o
+ obj-pci-$(CONFIG_MACH_GATEWAY7001)    += gateway7001-pci.o
++obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
+ obj-y += common.o
+@@ -22,5 +23,6 @@
+ obj-$(CONFIG_MACH_NSLU2)      += nslu2-setup.o nslu2-power.o
+ obj-$(CONFIG_MACH_NAS100D)    += nas100d-setup.o nas100d-power.o
+ obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
++obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
+ obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
+diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-pci.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-pci.c
+--- linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-pci.c  1970-01-01 01:00:00.000000000 +0100
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-pci.c     2007-04-02 16:00:12.000000000 +0200
+@@ -0,0 +1,68 @@
++/*
++ * arch/arch/mach-ixp4xx/wg302v2-pci.c
++ *
++ * PCI setup routines for the Netgear WG302 v2 and WAG302 v2
++ *
++ * Copyright (C) 2006 Imre Kaloz <kaloz@openwrt.org>
++ *
++ * based on coyote-pci.c:
++ *    Copyright (C) 2002 Jungo Software Technologies.
++ *    Copyright (C) 2003 MontaVista Software, Inc.
++ *
++ * Maintainer: Imre Kaloz <kaloz@openwrt.org>
++ *
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License version 2 as
++ * published by the Free Software Foundation.
++ *
++ */
++
++#include <linux/kernel.h>
++#include <linux/pci.h>
++#include <linux/init.h>
++#include <linux/irq.h>
++
++#include <asm/mach-types.h>
++#include <asm/hardware.h>
++#include <asm/irq.h>
++
++#include <asm/mach/pci.h>
++
++extern void ixp4xx_pci_preinit(void);
++extern int ixp4xx_setup(int nr, struct pci_sys_data *sys);
++extern struct pci_bus *ixp4xx_scan_bus(int nr, struct pci_sys_data *sys);
++
++void __init wg302v2_pci_preinit(void)
++{
++      set_irq_type(IRQ_IXP4XX_GPIO8, IRQT_LOW);
++      set_irq_type(IRQ_IXP4XX_GPIO9, IRQT_LOW);
++
++      ixp4xx_pci_preinit();
++}
++
++static int __init wg302v2_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
++{
++      if (slot == 1)
++              return IRQ_IXP4XX_GPIO8;
++      else if (slot == 2)
++              return IRQ_IXP4XX_GPIO9;
++      else return -1;
++}
++
++struct hw_pci wg302v2_pci __initdata = {
++      .nr_controllers = 1,
++      .preinit =        wg302v2_pci_preinit,
++      .swizzle =        pci_std_swizzle,
++      .setup =          ixp4xx_setup,
++      .scan =           ixp4xx_scan_bus,
++      .map_irq =        wg302v2_map_irq,
++};
++
++int __init wg302v2_pci_init(void)
++{
++      if (machine_is_wg302v2())
++              pci_common_init(&wg302v2_pci);
++      return 0;
++}
++
++subsys_initcall(wg302v2_pci_init);
+diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-setup.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-setup.c
+--- linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-setup.c        1970-01-01 01:00:00.000000000 +0100
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-setup.c   2007-04-02 16:08:57.000000000 +0200
+@@ -0,0 +1,107 @@
++/*
++ * arch/arm/mach-ixp4xx/wg302-setup.c
++ *
++ * Board setup for the Netgear WG302 v2 and WAG302 v2
++ *
++ * based on coyote-setup.c:
++ *     Copyright (C) 2003-2005 MontaVista Software, Inc.
++ *
++ * Maintainer: Imre Kaloz <kaloz@openwrt.org>
++ *
++ */
++
++#include <linux/kernel.h>
++#include <linux/init.h>
++#include <linux/device.h>
++#include <linux/serial.h>
++#include <linux/tty.h>
++#include <linux/serial_8250.h>
++#include <linux/slab.h>
++
++#include <asm/types.h>
++#include <asm/setup.h>
++#include <asm/memory.h>
++#include <asm/hardware.h>
++#include <asm/irq.h>
++#include <asm/mach-types.h>
++#include <asm/mach/arch.h>
++#include <asm/mach/flash.h>
++
++static struct flash_platform_data wg302v2_flash_data = {
++      .map_name       = "cfi_probe",
++      .width          = 2,
++};
++
++static struct resource wg302v2_flash_resource = {
++      .flags          = IORESOURCE_MEM,
++};
++
++static struct platform_device wg302v2_flash = {
++      .name           = "IXP4XX-Flash",
++      .id             = 0,
++      .dev            = {
++              .platform_data = &wg302v2_flash_data,
++      },
++      .num_resources  = 1,
++      .resource       = &wg302v2_flash_resource,
++};
++
++static struct resource wg302v2_uart_resource = {
++      .start  = IXP4XX_UART2_BASE_PHYS,
++      .end    = IXP4XX_UART2_BASE_PHYS + 0x0fff,
++      .flags  = IORESOURCE_MEM,
++};
++
++static struct plat_serial8250_port wg302v2_uart_data[] = {
++      {
++              .mapbase        = IXP4XX_UART2_BASE_PHYS,
++              .membase        = (char *)IXP4XX_UART2_BASE_VIRT + REG_OFFSET,
++              .irq            = IRQ_IXP4XX_UART2,
++              .flags          = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
++              .iotype         = UPIO_MEM,
++              .regshift       = 2,
++              .uartclk        = IXP4XX_UART_XTAL,
++      },
++      { },
++};
++
++static struct platform_device wg302v2_uart = {
++      .name           = "serial8250",
++      .id             = PLAT8250_DEV_PLATFORM,
++      .dev                    = {
++              .platform_data  = wg302v2_uart_data,
++      },
++      .num_resources  = 1,
++      .resource       = &wg302v2_uart_resource,
++};
++
++static struct platform_device *wg302v2_devices[] __initdata = {
++      &wg302v2_flash,
++      &wg302v2_uart,
++};
++
++static void __init wg302v2_init(void)
++{
++      ixp4xx_sys_init();
++
++      wg302v2_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
++      wg302v2_flash_resource.end = IXP4XX_EXP_BUS_BASE(0) + SZ_32M - 1;
++
++      *IXP4XX_EXP_CS0 |= IXP4XX_FLASH_WRITABLE;
++      *IXP4XX_EXP_CS1 = *IXP4XX_EXP_CS0;
++
++      platform_add_devices(wg302v2_devices, ARRAY_SIZE(wg302v2_devices));
++}
++
++#ifdef CONFIG_ARCH_WG302V2
++MACHINE_START(WG302V2, "Netgear WG302 v2 / WAG302 v2")
++      /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
++      .phys_io        = IXP4XX_PERIPHERAL_BASE_PHYS,
++      .io_pg_offst    = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
++      .map_io         = ixp4xx_map_io,
++      .init_irq       = ixp4xx_init_irq,
++      .timer          = &ixp4xx_timer,
++      .boot_params    = 0x0100,
++      .init_machine   = wg302v2_init,
++MACHINE_END
++#endif
+diff -Nur linux-2.6.19.2/include/asm-arm/arch-ixp4xx/uncompress.h linux-2.6.19.2-owrt/include/asm-arm/arch-ixp4xx/uncompress.h
+--- linux-2.6.19.2/include/asm-arm/arch-ixp4xx/uncompress.h    2007-04-02 16:09:06.000000000 +0200
++++ linux-2.6.19.2-owrt/include/asm-arm/arch-ixp4xx/uncompress.h       2007-04-02 16:02:04.000000000 +0200
+@@ -40,7 +40,7 @@
+       /*
+        * Some boards are using UART2 as console
+        */
+-      if (machine_is_adi_coyote() || machine_is_gtwx5715() || machine_is_gateway7001())
++      if (machine_is_adi_coyote() || machine_is_gtwx5715() || machine_is_gateway7001() || machine_is_wg302v2())
+               uart_base = (volatile u32*) IXP4XX_UART2_BASE_PHYS;
+       else
+               uart_base = (volatile u32*) IXP4XX_UART1_BASE_PHYS;
diff --git a/target/linux/ixp4xx-2.6/patches/310-wg302v2_setup_mac.patch b/target/linux/ixp4xx-2.6/patches/310-wg302v2_setup_mac.patch
new file mode 100644 (file)
index 0000000..27616e1
--- /dev/null
@@ -0,0 +1,37 @@
+diff -Nur linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-setup.c linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-setup.c
+--- linux-2.6.19.2/arch/arm/mach-ixp4xx/wg302v2-setup.c        2007-04-02 16:06:02.000000000 +0200
++++ linux-2.6.19.2-owrt/arch/arm/mach-ixp4xx/wg302v2-setup.c   2007-03-05 11:57:24.000000000 +0100
+@@ -75,9 +75,33 @@
+       .resource       = &wg302v2_uart_resource,
+ };
++static struct resource res_mac0 = {
++      .start          = IXP4XX_EthB_BASE_PHYS,
++      .end            = IXP4XX_EthB_BASE_PHYS + 0x1ff,
++      .flags          = IORESOURCE_MEM,
++};
++
++static struct mac_plat_info plat_mac0 = {
++      .npe_id         = 1,
++      .phy_id         = 8,
++      .eth_id         = 0,
++      .rxq_id         = 27,
++      .txq_id         = 24,
++      .rxdoneq_id     = 4,
++};
++
++static struct platform_device mac0 = {
++      .name           = "ixp4xx_mac",
++      .id             = 0,
++      .dev.platform_data = &plat_mac0,
++      .num_resources  = 1,
++      .resource       = &res_mac0,
++};
++
+ static struct platform_device *wg302v2_devices[] __initdata = {
+       &wg302v2_flash,
+       &wg302v2_uart,
++      &mac0,
+ };
+ static void __init wg302v2_init(void)