mac80211: b43: Add Firmware 5.10.56.27
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Apr 2011 21:40:08 +0000 (21:40 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Apr 2011 21:40:08 +0000 (21:40 +0000)
Add the 5.10.56.27 firmware option. This includes updating b43-fwcutter to
its newest release 14 and updating the b43-fwsquash.py to recognise rev 16
n phy files.

Also rename the current options from STABLE/EXPERIMENTAL to their version
numbers.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@26733 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile
package/mac80211/files/host_bin/b43-fwsquash.py

index 219a392..4de6b12 100644 (file)
@@ -916,7 +916,15 @@ define KernelPackage/mwl8k/description
 endef
 
 #Broadcom firmware
-ifneq ($(CONFIG_B43_EXPERIMENTAL),)
+ifneq ($(CONFIG_B43_FW_5_10),)
+  PKG_B43_FWV4_NAME:=broadcom-wl
+  PKG_B43_FWV4_VERSION:=5.10.56.27.3
+  PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)/driver/wl_apsta/wl_prebuilt.o
+  PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)_mipsel.tar.bz2
+  PKG_B43_FWV4_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+  PKG_B43_FWV4_MD5SUM:=3363e3a6b3d9d73c49dea870c7834eac
+else
+ifneq ($(CONFIG_B43_FW_4_178),)
   PKG_B43_FWV4_NAME:=broadcom-wl
   PKG_B43_FWV4_VERSION:=4.178.10.4
   PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)/linux/wl_apsta.o
@@ -931,6 +939,7 @@ else
   PKG_B43_FWV4_SOURCE_URL:=http://mirror2.openwrt.org/sources/
   PKG_B43_FWV4_MD5SUM:=0c6ba9687114c6b598e8019e262d9a60
 endif
+endif
 ifneq ($(CONFIG_B43_OPENFIRMWARE),)
   PKG_B43_FWV4_NAME:=broadcom-wl
   PKG_B43_FWV4_VERSION:=5.2
@@ -957,11 +966,11 @@ ifeq ($(CONFIG_B43_OPENFIRMWARE),y)
   PKG_B43_FWCUTTER_OBJECT:=$(PKG_B43_FWCUTTER_NAME)-$(PKG_B43_FWCUTTER_VERSION)/fwcutter/
 else
   PKG_B43_FWCUTTER_NAME:=b43-fwcutter
-  PKG_B43_FWCUTTER_VERSION:=013
+  PKG_B43_FWCUTTER_VERSION:=014
   PKG_B43_FWCUTTER_SOURCE:=$(PKG_B43_FWCUTTER_NAME)-$(PKG_B43_FWCUTTER_VERSION).tar.bz2
   PKG_B43_FWCUTTER_PROTO:=default
   PKG_B43_FWCUTTER_SOURCE_URL:=http://bu3sch.de/b43/fwcutter/
-  PKG_B43_FWCUTTER_MD5SUM:=3547ec6c474ac1bc2c4a5bb765b791a4
+  PKG_B43_FWCUTTER_MD5SUM:=dd63f9149510bd6e01b89314e955083b
   PKG_B43_FWCUTTER_SUBDIR:=b43-fwcutter-$(PKG_B43_FWCUTTER_VERSION)
   PKG_B43_FWCUTTER_OBJECT:=$(PKG_B43_FWCUTTER_NAME)-$(PKG_B43_FWCUTTER_VERSION)/
 endif
@@ -1013,19 +1022,19 @@ define KernelPackage/b43/config
 
        choice
                prompt "b43 firmware version"
-               default B43_STABLE
+               default B43_FW_4_150
                help
                  This option allows you to select the version of the b43 firmware.
 
-       config B43_STABLE
-               bool "4.150.10.5 (stable)"
+       config B43_FW_4_150
+               bool "Firmware 410.2160 from driver 4.150.10.5 (stable)"
                help
                  Stable firmware for BCM43xx devices.
 
                  If unsure, select this.
 
-       config B43_EXPERIMENTAL
-               bool "4.178.10.4 (experimental)"
+       config B43_FW_4_178
+               bool "Firmware 478.104 from driver 4.178.10.4"
                help
                  Experimental firmware for BCM43xx devices.
 
@@ -1033,6 +1042,15 @@ define KernelPackage/b43/config
 
                  If unsure, select the "stable" firmware.
 
+       config B43_FW_5_10
+               bool "Firmware 508.1084 from driver 5.10.56.27"
+               help
+                 Newer experimental firmware for BCM43xx devices.
+
+                 This firmware is mostly untested. It is needed for some N-PHY devices.
+
+                 If unsure, select the "stable" firmware.
+
        config B43_OPENFIRMWARE
                bool "Open FirmWare for WiFi networks"
                help
index ba47da8..1e36964 100755 (executable)
@@ -69,6 +69,7 @@ revmapping = {
        "ucode13.fw"            : (13,),
        "ucode14.fw"            : (14,),
        "ucode15.fw"            : (15,),
+       "ucode16_mimo.fw"       : (16,),
        "pcm4.fw"               : (1,2,3,4,),
        "pcm5.fw"               : (5,6,7,8,9,10,),
 }
@@ -80,6 +81,7 @@ initvalmapping = {
        "b0g0initvals5.fw"      : ( (5,6,7,8,9,10,),    ("G",), ),
        "b0g0initvals13.fw"     : ( (13,),              ("G",), ),
        "n0initvals11.fw"       : ( (11,12,),           ("N",), ),
+       "n0initvals16.fw"       : ( (16,),              ("N",), ),
        "lp0initvals13.fw"      : ( (13,),              ("LP",), ),
        "lp0initvals14.fw"      : ( (14,),              ("LP",), ),
        "lp0initvals15.fw"      : ( (15,),              ("LP",), ),
@@ -87,6 +89,7 @@ initvalmapping = {
        "a0g0bsinitvals5.fw"    : ( (5,6,7,8,9,10,),    ("A", "AG"), ),
        "b0g0bsinitvals5.fw"    : ( (5,6,7,8,9,10,),    ("G",), ),
        "n0bsinitvals11.fw"     : ( (11,12,),           ("N",), ),
+       "n0bsinitvals16.fw"     : ( (16,),              ("N",), ),
        "lp0bsinitvals13.fw"    : ( (13,),              ("LP",), ),
        "lp0bsinitvals14.fw"    : ( (14,),              ("LP",), ),
        "lp0bsinitvals15.fw"    : ( (15,),              ("LP",), ),