[lantiq] fix i2c-lantiq module
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Dec 2012 10:03:18 +0000 (10:03 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 16 Dec 2012 10:03:18 +0000 (10:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34712 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/modules.mk

index 9022318..e7fbad3 100644 (file)
@@ -5,18 +5,18 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
-I2C_FALCON_MODULES:= \
-  CONFIG_I2C_FALCON:drivers/i2c/busses/i2c-falcon
+I2C_LANTIQ_MODULES:= \
+  CONFIG_I2C_LANTIQ:drivers/i2c/busses/i2c-lantiq
 
 
-define KernelPackage/i2c-falcon-lantiq
-  TITLE:=Falcon I2C controller
-  $(call i2c_defaults,$(I2C_FALCON_MODULES),52)
-  DEPENDS:=kmod-i2c-core @(TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable)
+define KernelPackage/i2c-lantiq
+  TITLE:=Lantiq I2C controller
+  $(call i2c_defaults,$(I2C_LANTIQ_MODULES),52)
+  DEPENDS:=kmod-i2c-core @TARGET_lantiq_falcon
 endef
 
 endef
 
-define KernelPackage/i2c-falcon-lantiq/description
-  Kernel support for the Falcon I2C controller
+define KernelPackage/i2c-lantiq/description
+  Kernel support for the Lantiq/Falcon I2C controller
 endef
 
 endef
 
-$(eval $(call KernelPackage,i2c-falcon-lantiq))
+$(eval $(call KernelPackage,i2c-lantiq))