modules: make kmod-pcspkr depend on X86
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Mar 2014 23:15:56 +0000 (23:15 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Mar 2014 23:15:56 +0000 (23:15 +0000)
The kernel Kconfig dependency lists X86, and we will fail building this module
on other platforms such as Malta.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39974 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/sound.mk

index 777d274..ebdd3d9 100644 (file)
@@ -262,7 +262,7 @@ $(eval $(call KernelPackage,sound-soc-gw_avila))
 
 
 define KernelPackage/pcspkr
-  DEPENDS:=@!TARGET_x86
+  DEPENDS:=@TARGET_x86
   TITLE:=PC speaker support
   KCONFIG:= \
        CONFIG_INPUT_PCSPKR \