6in4: make local ip6addr optional
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Oct 2012 09:17:14 +0000 (09:17 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Oct 2012 09:17:14 +0000 (09:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33761 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/6in4/Makefile
package/network/ipv6/6in4/files/6in4.sh

index fdab290..fcb0a7e 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6in4
-PKG_VERSION:=11
+PKG_VERSION:=12
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 71bc689..651d7b9 100755 (executable)
@@ -17,7 +17,7 @@ proto_6in4_setup() {
        local mtu ttl ipaddr peeraddr ip6addr tunnelid username password
        json_get_vars mtu ttl ipaddr peeraddr ip6addr tunnelid username password
 
        local mtu ttl ipaddr peeraddr ip6addr tunnelid username password
        json_get_vars mtu ttl ipaddr peeraddr ip6addr tunnelid username password
 
-       [ -z "$ip6addr" -o -z "$peeraddr" ] && {
+       [ -z "$peeraddr" ] && {
                proto_notify_error "$cfg" "MISSING_ADDRESS"
                proto_block_restart "$cfg"
                return
                proto_notify_error "$cfg" "MISSING_ADDRESS"
                proto_block_restart "$cfg"
                return
@@ -33,14 +33,16 @@ proto_6in4_setup() {
                fi
        }
 
                fi
        }
 
-       local local6="${ip6addr%%/*}"
-       local mask6="${ip6addr##*/}"
-       [[ "$local6" = "$mask6" ]] && mask6=
-
        proto_init_update "$link" 1
        proto_init_update "$link" 1
-       proto_add_ipv6_address "$local6" "$mask6"
        proto_add_ipv6_route "::" 0
 
        proto_add_ipv6_route "::" 0
 
+       [ -n "$ip6addr" ] && {
+               local local6="${ip6addr%%/*}"
+               local mask6="${ip6addr##*/}"
+               [[ "$local6" = "$mask6" ]] && mask6=
+               proto_add_ipv6_address "$local6" "$mask6"
+       }
+
        proto_add_tunnel
        json_add_string mode sit
        json_add_int mtu "${mtu:-1280}"
        proto_add_tunnel
        json_add_string mode sit
        json_add_int mtu "${mtu:-1280}"