resolveip: fix endless getopt() loop when compiled for arm (#12290)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 8 Nov 2012 10:48:08 +0000 (10:48 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 8 Nov 2012 10:48:08 +0000 (10:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34116 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/resolveip/Makefile
package/network/utils/resolveip/src/resolveip.c

index 4b3e3d4..d1e675e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=resolveip
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 include $(INCLUDE_DIR)/package.mk
 
index 310f35f..43c5ae7 100644 (file)
@@ -35,7 +35,7 @@ static void show_usage(void)
 int main(int argc, char **argv)
 {
        int timeout = 3;
-       char opt;
+       int opt;
        char ipaddr[INET6_ADDRSTRLEN];
        void *addr;
        struct addrinfo *res, *rp;
@@ -49,7 +49,7 @@ int main(int argc, char **argv)
 
        while ((opt = getopt(argc, argv, "46t:h")) > -1)
        {
-               switch (opt)
+               switch ((char)opt)
                {
                        case '4':
                                hints.ai_family = AF_INET;