netifd: update, prefix proto handler callbacks with 'proto_'
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Oct 2011 20:28:42 +0000 (20:28 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Oct 2011 20:28:42 +0000 (20:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28632 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/netifd/Makefile
package/netifd/files/lib/netifd/proto/ppp.sh

index a9b6872..3fc309f 100644 (file)
@@ -7,7 +7,7 @@ PKG_RELEASE=$(PKG_SOURCE_VERSION)
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/netifd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=3c1a5bf324c8f2476239c4e49687ca252d3bf4c8
+PKG_SOURCE_VERSION:=24ccfe7d353ceb0ee4f8d4967604585de92fc9d0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 # PKG_MIRROR_MD5SUM:=
 # CMAKE_INSTALL:=1
index 7cff2a9..5f549bf 100755 (executable)
@@ -90,31 +90,31 @@ ppp_generic_teardown() {
 
 # PPP on serial device
 
-ppp_init_config() {
+proto_ppp_init_config() {
        proto_config_add_string "device"
        ppp_generic_init_config
        no_device=1
        available=1
 }
 
-ppp_setup() {
+proto_ppp_setup() {
        local config="$1"
 
        json_get_var device device
        ppp_generic_setup "$config" "$device"
 }
 
-ppp_teardown() {
+proto_ppp_teardown() {
        ppp_generic_teardown "$@"
 }
 
-pppoe_init_config() {
+proto_pppoe_init_config() {
        ppp_generic_init_config
        proto_config_add_string "ac"
        proto_config_add_string "service"
 }
 
-pppoe_setup() {
+proto_pppoe_setup() {
        local config="$1"
        local iface="$2"
 
@@ -135,11 +135,11 @@ pppoe_setup() {
                "nic-$iface"
 }
 
-pppoe_teardown() {
+proto_pppoe_teardown() {
        ppp_generic_teardown "$@"
 }
 
-pppoa_init_config() {
+proto_pppoa_init_config() {
        ppp_generic_init_config
        proto_config_add_int "atmdev"
        proto_config_add_int "vci"
@@ -147,7 +147,7 @@ pppoa_init_config() {
        proto_config_add_string "encaps"
 }
 
-pppoa_setup() {
+proto_pppoa_setup() {
        local config="$1"
        local iface="$2"
 
@@ -171,7 +171,7 @@ pppoa_setup() {
                ${encaps}
 }
 
-pppoa_teardown() {
+proto_pppoa_teardown() {
        ppp_generic_teardown "$@"
 }