kernel: update kernel 4.1 to version 4.1.23
authorrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 May 2016 14:56:57 +0000 (14:56 +0000)
committerrmilecki <rmilecki@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 May 2016 14:56:57 +0000 (14:56 +0000)
Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49296 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/bcm53xx/patches-4.1/191-usb-xhci-add-Broadcom-specific-fake-doorbell.patch
target/linux/generic/patches-4.1/040-fs-overlay-fix-stacking.patch
target/linux/generic/patches-4.1/111-jffs2-add-RENAME_EXCHANGE-support.patch
target/linux/generic/patches-4.1/204-module_strip.patch
target/linux/generic/patches-4.1/300-mips_expose_boot_raw.patch
target/linux/generic/patches-4.1/304-mips_disable_fpu.patch
target/linux/generic/patches-4.1/903-debloat_direct_io.patch

index 51417ff..ba6bf66 100644 (file)
@@ -3,12 +3,12 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .29
-LINUX_VERSION-4.1 = .20
+LINUX_VERSION-4.1 = .23
 LINUX_VERSION-4.3 = .4
 LINUX_VERSION-4.4 = .7
 
 LINUX_KERNEL_MD5SUM-3.18.29 = b25737a0bc98e80d12200de93f239c28
-LINUX_KERNEL_MD5SUM-4.1.20 = 075c38a3a23ca5bc80437b13606df00a
+LINUX_KERNEL_MD5SUM-4.1.23 = 5cb969fa874e110118722398b7c72c5d
 LINUX_KERNEL_MD5SUM-4.3.4 = 5275d02132107c28b85f986bad576d91
 LINUX_KERNEL_MD5SUM-4.4.7 = 4345597c9a10bd73c28b6ae3a854d8d7
 
index 535bc69..8f1d883 100644 (file)
@@ -74,7 +74,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  /*
   * Set the run bit and wait for the host to be running.
   */
-@@ -567,10 +600,25 @@ int xhci_init(struct usb_hcd *hcd)
+@@ -568,10 +601,25 @@ int xhci_init(struct usb_hcd *hcd)
  
  static int xhci_run_finished(struct xhci_hcd *xhci)
  {
@@ -103,7 +103,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
        xhci->shared_hcd->state = HC_STATE_RUNNING;
        xhci->cmd_ring_state = CMD_RING_STATE_RUNNING;
  
-@@ -580,6 +628,9 @@ static int xhci_run_finished(struct xhci
+@@ -581,6 +629,9 @@ static int xhci_run_finished(struct xhci
        xhci_dbg_trace(xhci, trace_xhci_dbg_init,
                        "Finished xhci_run for USB3 roothub");
        return 0;
@@ -115,11 +115,11 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
  /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1571,6 +1571,7 @@ struct xhci_hcd {
- #define XHCI_BROKEN_STREAMS   (1 << 19)
+@@ -1573,6 +1573,7 @@ struct xhci_hcd {
  #define XHCI_PME_STUCK_QUIRK  (1 << 20)
  #define XHCI_SSIC_PORT_UNUSED (1 << 22)
-+#define XHCI_FAKE_DOORBELL    (1 << 23)
+ #define XHCI_NO_64BIT_SUPPORT (1 << 23)
++#define XHCI_FAKE_DOORBELL    (1 << 24)
        unsigned int            num_active_eps;
        unsigned int            limit_active_eps;
        /* There are two roothubs to keep track of bus suspend info for */
index 6c13e5f..bc54141 100644 (file)
@@ -21,7 +21,7 @@ Cc: <stable@vger.kernel.org> # v4.2+
 
 --- a/fs/overlayfs/inode.c
 +++ b/fs/overlayfs/inode.c
-@@ -375,6 +375,9 @@ struct inode *ovl_d_select_inode(struct
+@@ -377,6 +377,9 @@ struct inode *ovl_d_select_inode(struct
                ovl_path_upper(dentry, &realpath);
        }
  
index 3cc7b90..625f218 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        else
                /* Unlink the original */
                ret = jffs2_do_unlink(c, JFFS2_INODE_INFO(old_dir_i),
-@@ -879,7 +885,7 @@ static int jffs2_rename (struct inode *o
+@@ -884,7 +890,7 @@ static int jffs2_rename (struct inode *o
                return ret;
        }
  
index ab2fd17..220e8dc 100644 (file)
@@ -109,7 +109,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  config INIT_ALL_POSSIBLE
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -2685,6 +2685,7 @@ static struct module *setup_load_info(st
+@@ -2704,6 +2704,7 @@ static struct module *setup_load_info(st
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -117,7 +117,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        const char *modmagic = get_modinfo(info, "vermagic");
        int err;
  
-@@ -2710,6 +2711,7 @@ static int check_modinfo(struct module *
+@@ -2729,6 +2730,7 @@ static int check_modinfo(struct module *
                pr_warn("%s: module is from the staging directory, the quality "
                        "is unknown, you have been warned.\n", mod->name);
        }
index 49f2ded..b9cf5ba 100644 (file)
@@ -18,7 +18,7 @@ Acked-by: Rob Landley <rob@landley.net>
  config CEVT_BCM1480
        bool
  
-@@ -2676,6 +2673,18 @@ config USE_OF
+@@ -2677,6 +2674,18 @@ config USE_OF
  config BUILTIN_DTB
        bool
  
index 7dc2ac9..b65d258 100644 (file)
@@ -26,7 +26,7 @@ v2: incorporated changes suggested by Jonas Gorski
 \r
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2668,6 +2668,20 @@ config MIPS_O32_FP64_SUPPORT
+@@ -2669,6 +2669,20 @@ config MIPS_O32_FP64_SUPPORT
  
          If unsure, say N.
  
index ca35e57..92e36f0 100644 (file)
@@ -26,7 +26,7 @@
  endif
 --- a/include/linux/fs.h
 +++ b/include/linux/fs.h
-@@ -2657,6 +2657,7 @@ enum {
+@@ -2659,6 +2659,7 @@ enum {
        DIO_SKIP_DIO_COUNT = 0x08,
  };
  
@@ -34,7 +34,7 @@
  void dio_end_io(struct bio *bio, int error);
  
  ssize_t __blockdev_direct_IO(struct kiocb *iocb, struct inode *inode,
-@@ -2664,6 +2665,18 @@ ssize_t __blockdev_direct_IO(struct kioc
+@@ -2666,6 +2667,18 @@ ssize_t __blockdev_direct_IO(struct kioc
                             loff_t offset, get_block_t get_block,
                             dio_iodone_t end_io, dio_submit_t submit_io,
                             int flags);