ar71xx: add support for TP-Link TL-WDR3600
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 09:43:18 +0000 (09:43 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 09:43:18 +0000 (09:43 +0000)
The TL-WDR3600 is identical to the TL-WDR4300 with the exception that is has
only two antennas.

[juhosg: remove the custom machine type, change the board name instead]

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33219 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wdr4300.c
target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.3/610-MIPS-ath79-openwrt-machines.patch

index 648cca8..23d34a3 100755 (executable)
@@ -123,6 +123,9 @@ tplink_board_detect() {
        "342000"*)
                model="TP-Link TL-MR3420"
                ;;
+       "360000"*)
+               model="TP-Link TL-WDR3600"
+               ;;
        "430000"*)
                model="TP-Link TL-WDR4300"
                ;;
@@ -321,7 +324,7 @@ ar71xx_board_detect() {
        *"TL-WA901ND v2")
                name="tl-wa901nd-v2"
                ;;
-       *TL-WDR4300)
+       *"TL-WDR3600/4300/4310")
                name="tl-wdr4300"
                ;;
        *TL-WR741ND)
index 6b3b1fe..331de56 100644 (file)
@@ -199,5 +199,6 @@ static void __init wdr4300_setup(void)
        ath79_register_usb();
 }
 
-MIPS_MACHINE(ATH79_MACH_TL_WDR4300, "TL-WDR4300", "TP-LINK TL-WDR4300",
+MIPS_MACHINE(ATH79_MACH_TL_WDR4300, "TL-WDR4300",
+            "TP-LINK TL-WDR3600/4300/4310",
             wdr4300_setup);
index 74355e8..056a917 100644 (file)
@@ -95,12 +95,12 @@ $(eval $(call Profile,TLWA901))
 
 
 define Profile/TLWDR4300
-       NAME:=TP-LINK TL-WDR4300/ TL-WDR4310
+       NAME:=TP-LINK TL-WDR3600/4300/4310
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLWDR4300/Description
-       Package set optimized for the TP-LINK TL-WDR4300.
+       Package set optimized for the TP-LINK TL-WDR3600/4300/4310.
 endef
 $(eval $(call Profile,TLWDR4300))
 
index 26ac0ab..43bb9d3 100644 (file)
@@ -991,6 +991,7 @@ endef
 
 tlwdr4300_cmdline=board=TL-WDR4300 console=ttyS0,115200
 define Image/Build/Profile/TLWDR4300
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr3600-v1,$(tlwdr4300_cmdline),0x36000001,1,8Mlzma)
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4300-v1,$(tlwdr4300_cmdline),0x43000001,1,8Mlzma)
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4310-v1,$(tlwdr4300_cmdline),0x43100001,1,8Mlzma)
 endef
index 4179681..73db5e4 100644 (file)
 +      select ATH79_DEV_WMAC
 +
 +config ATH79_MACH_TL_WDR4300
-+      bool "TP-LINK TL-WDR4300 board support"
++      bool "TP-LINK TL-WDR3600/4300/4310 board support"
 +      select SOC_AR934X
 +      select ATH79_DEV_AP9X_PCI if PCI
 +      select ATH79_DEV_ETH