strace: cross compile fix: pass HOST_*FLAGS in to ./configure
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Jul 2015 14:59:09 +0000 (14:59 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 19 Jul 2015 14:59:09 +0000 (14:59 +0000)
The HOST_*FLAGS are for compiling programs which will run on the machine that is
running the build.  Setting these flags is frequently required for unusual
cross-compiles.

Signed-off-by: Lawrence D'Anna <larry@elder-gods.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46422 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/devel/strace/Makefile

index eb80791..b9ed201 100644 (file)
@@ -27,6 +27,12 @@ PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
+CONFIGURE_VARS+= \
+       LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
+       CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \
+       CFLAGS_FOR_BUILD="$(HOST_CFLAGS)" \
+       CC_FOR_BUILD="$(HOST_CC)"
+
 define Package/strace
   SECTION:=utils
   CATEGORY:=Utilities