Allow colored output to be disabled when running a non-verbose build by
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Feb 2010 22:28:19 +0000 (22:28 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Feb 2010 22:28:19 +0000 (22:28 +0000)
setting NO_COLOR=1

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19560 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/verbose.mk

index 857be24..9fe27ce 100644 (file)
@@ -18,8 +18,10 @@ ifeq ("$(origin V)", "command line")
 endif
 
 ifeq ($(IS_TTY),1)
-  _Y:=\\033[33m
-  _N:=\\033[m
+  ifneq ($(strip $(NO_COLOR)),1)
+    _Y:=\\033[33m
+    _N:=\\033[m
+  endif
 endif
 
 ifneq ($(KBUILD_VERBOSE),99)