fix mistakes in unpack change
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Oct 2006 13:04:50 +0000 (13:04 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Oct 2006 13:04:50 +0000 (13:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5077 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk
include/package.mk
include/unpack.mk

index 858eee5..0502d76 100644 (file)
@@ -8,9 +8,9 @@
 include $(INCLUDE_DIR)/host.mk
 include $(INCLUDE_DIR)/unpack.mk
 
-ifneq ($(strip $(UNPACK)),)
+ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
-       $(UNPACK)
+       $(PKG_UNPACK)
        @if [ -d ./patches ]; then \
                $(PATCH) $(PKG_BUILD_DIR) ./patches; \
        fi
index fc1b780..706b38d 100644 (file)
@@ -272,7 +272,7 @@ endef
 
 ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
-       $(UNPACK)
+       $(PKG_UNPACK)
        @if [ -d ./patches ]; then \
                $(PATCH) $(PKG_BUILD_DIR) ./patches; \
        fi
index 6449981..52764e4 100644 (file)
@@ -1,13 +1,13 @@
 ifeq ($(strip $(PKG_UNPACK)),)
   ifneq ($(strip $(PKG_CAT)),)
     # use existing PKG_CAT
-    UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+    PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
     ifeq ($(PKG_CAT),unzip)
-      UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
+      PKG_UNPACK=unzip -d $(PKG_BUILD_DIR) $(DL_DIR)/$(PKG_SOURCE)
     endif
     # replace zcat with $(ZCAT), because some system have it as gzcat
     ifeq ($(PKG_CAT),zcat)
-      UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
+      PKG_UNPACK:=$(ZCAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
     endif
   else
     # try to autodetect file type