iwinfo: properly initialize memory of global nl80211_state, fixes random libnl-tiny...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Oct 2012 22:11:57 +0000 (22:11 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Oct 2012 22:11:57 +0000 (22:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34003 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iwinfo/Makefile
package/network/utils/iwinfo/src/iwinfo_nl80211.c

index f05fe4a..bbef2bd 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libiwinfo
-PKG_RELEASE:=35
+PKG_RELEASE:=36
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_CONFIG_DEPENDS := \
index 304a18b..763ed61 100644 (file)
@@ -41,6 +41,8 @@ static int nl80211_init(void)
                        goto err;
                }
 
+               memset(nls, 0, sizeof(*nls));
+
                nls->nl_sock = nl_socket_alloc();
                if (!nls->nl_sock) {
                        err = -ENOMEM;