au1000: fix kmod-pcmcia-au1000
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 29 May 2015 11:03:55 +0000 (11:03 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 29 May 2015 11:03:55 +0000 (11:03 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45817 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/au1000/modules.mk

index e001db4..079a267 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,9 +8,10 @@
 define KernelPackage/pcmcia-au1000
   SUBMENU:=$(PCMCIA_MENU)
   TITLE:=RMI/AMD Au1000 PCMCIA support
-  DEPENDS:=@TARGET_au1000 kmod-pcmcia-core
-  FILES:=$(LINUX_DIR)/drivers/pcmcia/au1x00_ss.ko
-  AUTOLOAD:=$(call AutoLoad,41,au1x00_ss)
+  DEPENDS:=@TARGET_au1000 +kmod-pcmcia-core
+  FILES:=$(LINUX_DIR)/drivers/pcmcia/db1xxx_ss.ko
+  KCONFIG:=CONFIG_PCMCIA_ALCHEMY_DEVBOARD
+  AUTOLOAD:=$(call AutoLoad,41,db1xxx_ss)
 endef
 
 $(eval $(call KernelPackage,pcmcia-au1000))