add reboot fix for mtd (thanks, wbx)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 26 Nov 2006 01:03:21 +0000 (01:03 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 26 Nov 2006 01:03:21 +0000 (01:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5645 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mtd/Makefile
package/mtd/src/mtd.c

index 8444bd8..cf23fbe 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=mtd
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_BUILD_DIR := $(KERNEL_BUILD_DIR)/$(PKG_NAME)
 
index 80d09ab..7d1e360 100644 (file)
 #include <stdlib.h>
 #include <stdio.h>
 #include <stdint.h>
+#include <sys/ioctl.h>
+#include <sys/syscall.h>
 #include <fcntl.h>
 #include <errno.h>
 #include <error.h>
 #include <time.h>
+#include <string.h>
 #include <sys/ioctl.h>
 #include <sys/types.h>
 #include <sys/param.h>
 #include <sys/mount.h>
 #include <sys/stat.h>
 #include <sys/reboot.h>
-#include <string.h>
+#include <linux/reboot.h>
 
 #include "mtd.h"
 
@@ -458,8 +461,9 @@ int main (int argc, char **argv)
 
        sync();
        
-       if (boot)
-               kill(1, 15); // send SIGTERM to init for reboot
-
+       if (boot) {
+               fflush(stdout);
+               syscall(SYS_reboot,LINUX_REBOOT_MAGIC1,LINUX_REBOOT_MAGIC2,LINUX_REBOOT_CMD_RESTART,NULL);
+       }
        return 0;
 }