[tools] padjffs2: link statically
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 19:26:43 +0000 (19:26 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Aug 2012 19:26:43 +0000 (19:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33100 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/padjffs2/Makefile
tools/padjffs2/src/Makefile

index a949ac0..3f033c0 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2011-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -18,6 +18,10 @@ define Host/Prepare
        find $(HOST_BUILD_DIR) -name .svn | $(XARGS) rm -rf
 endef
 
        find $(HOST_BUILD_DIR) -name .svn | $(XARGS) rm -rf
 endef
 
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) LDFLAGS="-static"
+endef
+
 define Host/Configure
 endef
 
 define Host/Configure
 endef
 
index fe1a7aa..45da8e5 100644 (file)
@@ -9,7 +9,7 @@ all: padjffs2
        $(CC) $(CFLAGS) $(WFLAGS) -c -o $@ $<
 
 padjffs2: $(padjffs2-objs)
        $(CC) $(CFLAGS) $(WFLAGS) -c -o $@ $<
 
 padjffs2: $(padjffs2-objs)
-       $(CC) -o $@ $(padjffs2-objs)
+       $(CC) $(LDFLAGS) -o $@ $(padjffs2-objs)
 
 clean:
        rm -f padjffs2 *.o
 
 clean:
        rm -f padjffs2 *.o