tools: Fix mpfr build on FreeBSD 10.1
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Feb 2015 16:58:10 +0000 (16:58 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Feb 2015 16:58:10 +0000 (16:58 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44279 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/mpfr/patches/001-only_src.patch
tools/mpfr/patches/100-freebsd-compat.patch [new file with mode: 0644]

index e6579b2..51a75b4 100644 (file)
@@ -11,7 +11,7 @@
    examples/ReadMe examples/divworst.c examples/rndo-add.c examples/sample.c \
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -294,7 +294,7 @@ top_builddir = @top_builddir@
+@@ -295,7 +295,7 @@ top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
  AUTOMAKE_OPTIONS = gnu
  ACLOCAL_AMFLAGS = -I m4
diff --git a/tools/mpfr/patches/100-freebsd-compat.patch b/tools/mpfr/patches/100-freebsd-compat.patch
new file mode 100644 (file)
index 0000000..fa28a67
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/src/vasprintf.c
++++ b/src/vasprintf.c
+@@ -42,6 +42,7 @@ http://www.gnu.org/licenses/ or write to
+ #endif /* HAVE_VA_COPY */
+ #ifdef HAVE_WCHAR_H
++#include <stddef.h>
+ #include <wchar.h>
+ #endif