Zynq: Add Zedboard device support
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Apr 2016 11:44:26 +0000 (11:44 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Apr 2016 11:44:26 +0000 (11:44 +0000)
Tested-by: Joe Zhang <jz21082@gmail.com>
Signed-off-by: Jason Wu <jason.wu.misc@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49256 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/boot/uboot-zynq/Makefile
target/linux/zynq/base-files/etc/board.d/02_network
target/linux/zynq/image/Makefile
target/linux/zynq/profiles/zed.mk [new file with mode: 0644]

index 3a17f7f..2053e8d 100644 (file)
@@ -37,8 +37,13 @@ define uboot/zc706
        TITLE:=U-Boot $(PKG_VERSION) for Xilinx ZC706 Dev Board
 endef
 
        TITLE:=U-Boot $(PKG_VERSION) for Xilinx ZC706 Dev Board
 endef
 
+define uboot/zed
+       TITLE:=U-Boot $(PKG_VERSION) for Avnet Digilent ZedBoard Dev Board
+endef
+
 UBOOTS := \
        zc702 \
 UBOOTS := \
        zc702 \
+       zed \
 
 define Package/uboot/template
 define Package/uboot-zynq-$(1)
 
 define Package/uboot/template
 define Package/uboot-zynq-$(1)
index 71d6fd8..35667c0 100755 (executable)
@@ -6,7 +6,7 @@
 board_config_update
 
 case "$(cat /tmp/sysinfo/board_name)" in
 board_config_update
 
 case "$(cat /tmp/sysinfo/board_name)" in
-       xlnx,zynq-zc702)
+       xlnx,zynq-zc702|xlnx,zynq-zed)
                ucidef_set_interface_lan 'eth0'
                ;;
 esac
                ucidef_set_interface_lan 'eth0'
                ;;
 esac
index 99293a6..87975be 100644 (file)
@@ -70,6 +70,9 @@ define Device/ZC702
        $(call Device/DefaultConfig,zc702)
 endef
 
        $(call Device/DefaultConfig,zc702)
 endef
 
+define Device/ZED
+       $(call Device/DefaultConfig,zed)
+endef
 
 define Image/BuildKernel
        $(eval $(call Device/$(PROFILE)))
 
 define Image/BuildKernel
        $(eval $(call Device/$(PROFILE)))
diff --git a/target/linux/zynq/profiles/zed.mk b/target/linux/zynq/profiles/zed.mk
new file mode 100644 (file)
index 0000000..d8ff08b
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZED
+       NAME:=ZedBoard development baord
+endef
+
+define Profile/ZED/Description
+       Build firmware image for Avnet Digilent ZedBoard development board.
+endef
+
+$(eval $(call Profile,ZED))