kernel: update 3.10 to 3.10.10
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Sep 2013 19:12:54 +0000 (19:12 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Sep 2013 19:12:54 +0000 (19:12 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37890 3c298f89-4303-0410-b956-a3cf2f4a3e73

16 files changed:
include/kernel-version.mk
target/linux/ar71xx/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/brcm47xx/Makefile
target/linux/generic/patches-3.10/997-device_tree_cmdline.patch
target/linux/imx23/Makefile
target/linux/imx6/Makefile
target/linux/ixp4xx/Makefile
target/linux/malta/Makefile
target/linux/mpc85xx/Makefile
target/linux/octeon/Makefile
target/linux/ramips/Makefile
target/linux/realview/Makefile
target/linux/x86/alix2/target.mk
target/linux/xburst/Makefile

index c8fa401..b662f62 100644 (file)
@@ -17,8 +17,8 @@ endif
 ifeq ($(LINUX_VERSION),3.9.11)
   LINUX_KERNEL_MD5SUM:=edbf88eb7f7d34dbd5d3887726790755
 endif
-ifeq ($(LINUX_VERSION),3.10.9)
-  LINUX_KERNEL_MD5SUM:=28d1e1117c30fdd861f70ac0f9b677aa
+ifeq ($(LINUX_VERSION),3.10.10)
+  LINUX_KERNEL_MD5SUM:=647f76225dd6bc112369ba573ba3de18
 endif
 
 # disable the md5sum check for unknown kernel versions
index f32c6a3..20464f8 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs targz mips16
 CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 632b385..31e745c 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
 FEATURES:=squashfs usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 260237c..0a26248 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Broadcom BCM2708/BCM2835
 FEATURES:=ext4 audio usb usbgadget display gpio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
index 76994a1..4c80378 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += swconfig kmod-switch kmod-diag wpad-mini nvram
index 8009a29..7b8939a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/of/fdt.c
 +++ b/drivers/of/fdt.c
-@@ -677,6 +677,9 @@ int __init early_init_dt_scan_chosen(uns
+@@ -679,6 +679,9 @@ int __init early_init_dt_scan_chosen(uns
        p = of_get_flat_dt_prop(node, "bootargs", &l);
        if (p != NULL && l > 0)
                strlcpy(data, p, min((int)l, COMMAND_LINE_SIZE));
index 4eec4b9..def0a7a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale i.MX23 series
 FEATURES:=ext4 rtc usb gpio
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 KERNELNAME:="zImage dtbs"
 
 define Target/Description
index 3be83d0..b26e481 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
 CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 80c49e0..6be0098 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 6086120..bc1dfff 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 DEVICE_TYPE:=developerboard
 
index 077275f..93ba2c6 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 
index 903e83a..0085d22 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 pci usb
 CFLAGS:=-Os -pipe -march=octeon -fno-caller-saves
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 
index b477494..f806f24 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883 mt7620a
 CFLAGS:=-Os -pipe -mno-branch-likely
 FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 2ada518..84054bd 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 DEVICE_TYPE:=developerboard
 
index ff2ab15..780f471 100644 (file)
@@ -19,7 +19,7 @@ DEFAULT_PACKAGES += \
                        kmod-ledtrig-heartbeat kmod-ledtrig-gpio \
                        kmod-ledtrig-netdev \
                        kmod-cpu-msr hwclock wpad
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 CS5535_MASK:=0x0b000042
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \
index 1b527d0..ce1677f 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.10.9
+LINUX_VERSION:=3.10.10
 
 DEVICE_TYPE=other