automatically turn off colors
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Aug 2006 20:46:47 +0000 (20:46 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 4 Aug 2006 20:46:47 +0000 (20:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4454 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/verbose.mk

index 525fbf1..36002ae 100644 (file)
@@ -18,13 +18,18 @@ ifeq ("$(origin V)", "command line")
   KBUILD_VERBOSE:=$(V)
 endif
 
+ifneq ($(shell tty -s <&3 || echo x),x)
+  _Y:="\\33[33m"# yellow
+  _N:="\\33[m"#        normal
+endif
+
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
     trace: FORCE
        @[ -f "$(MAKECMDGOALS)" ] || { \
                [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
-               echo -e "\33[33mmake[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)\33[m" >&3; \
+               echo -e "$(_Y)make[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)$(_N)" >&3; \
        }
   else
     export QUIET:=1