build: prevent spurious host-build re-builds by touching .built after the install...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Dec 2014 20:14:27 +0000 (20:14 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 15 Dec 2014 20:14:27 +0000 (20:14 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43721 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk

index 126671a..ad821f7 100644 (file)
@@ -174,6 +174,7 @@ ifndef DUMP
                $(call Host/Install)
                $(foreach hook,$(Hooks/HostInstall/Post),$(call $(hook))$(sep))
                mkdir -p $$(shell dirname $$@)
+               touch $(HOST_STAMP_BUILT)
                touch $$@
 
   ifndef STAMP_BUILT