[package] base-files: update command line for the new hotplug2
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 May 2009 18:48:54 +0000 (18:48 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 28 May 2009 18:48:54 +0000 (18:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16154 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/init.d/boot
package/base-files/files/etc/preinit

index 6a697f1..3bb809f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=20
+PKG_RELEASE:=21
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 12226be..6ecddfb 100755 (executable)
@@ -52,7 +52,8 @@ start() {
 
        killall -q hotplug2
        [ -x /sbin/hotplug2 ] && /sbin/hotplug2 --override --persistent \
-                       --max-children 1 --no-coldplug >/dev/null 2>&1 &
+                       --set-worker /lib/hotplug2/worker_fork.so \
+                       --max-children 1 >/dev/null 2>&1 &
 
        # the coldplugging of network interfaces needs to happen later, so we do it manually here
        for iface in $(awk -F: '/:/ {print $1}' /proc/net/dev); do
index 7644383..4e706f1 100755 (executable)
@@ -32,8 +32,8 @@ if grep devfs /proc/filesystems > /dev/null; then
 elif [ -x /sbin/hotplug2 ]; then
        mount -t tmpfs tmpfs /dev -o size=512K
        mknod /dev/console c 5 1
-       /sbin/hotplug2 --coldplug --set-rules-file /etc/hotplug2-init.rules
-       /sbin/hotplug2 --no-coldplug --persistent --set-rules-file /etc/hotplug2-init.rules &
+       /sbin/hotplug2 --set-worker /lib/hotplug2/worker_fork.so --set-rules-file /etc/hotplug2-init.rules --no-persistent --set-coldplug-cmd /sbin/udevtrigger
+       /sbin/hotplug2 --set-worker /lib/hotplug2/worker_fork.so --set-rules-file /etc/hotplug2-init.rules --persistent &
        M0=/dev/ptmx
        M1=/dev/ptmx
        HOTPLUG=