ar71xx: fix mtd layout of the AP113
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 12:39:46 +0000 (12:39 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Aug 2012 12:39:46 +0000 (12:39 +0000)
The 'mtdparts=' prefix and the name of the flash device is missing.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33226 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index 18f7889..28c02f6 100644 (file)
@@ -666,7 +666,7 @@ define Image/Build/Profile/ALL0305
        $(call Image/Build/Template/$(fs_128k)/$(1),PB4X,all0305,$(all0305_cmdline))
 endef
 
-ap113_mtd_layout=64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
+ap113_mtd_layout=mtdparts=spi0.0:64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
 ap113_cmdline=board=AP113 console=ttyS0,115200
 define Image/Build/Profile/AP113
        $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,ap113,$(ap113_cmdline),$(ap113_mtd_layout),917504,3080192,RK)