ramips: add common gpio-buttons device
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Jan 2010 15:25:20 +0000 (15:25 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 Jan 2010 15:25:20 +0000 (15:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19404 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/dev-gpio-buttons.h [new file with mode: 0644]
target/linux/ramips/files/arch/mips/ralink/Kconfig
target/linux/ramips/files/arch/mips/ralink/common/Makefile
target/linux/ramips/files/arch/mips/ralink/common/dev-gpio-buttons.c [new file with mode: 0644]
target/linux/ramips/rt288x/config-2.6.30
target/linux/ramips/rt288x/config-2.6.32
target/linux/ramips/rt305x/config-2.6.30
target/linux/ramips/rt305x/config-2.6.32

diff --git a/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/dev-gpio-buttons.h b/target/linux/ramips/files/arch/mips/include/asm/mach-ralink/dev-gpio-buttons.h
new file mode 100644 (file)
index 0000000..c1ae71e
--- /dev/null
@@ -0,0 +1,31 @@
+/*
+ *  Ralink SoC GPIO button support
+ *
+ *  Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#ifndef __ASM_MACH_RALINK_DEV_GPIO_BUTTONS_H
+#define __ASM_MACH_RALINK_DEV_GPIO_BUTTONS_H
+
+#include <linux/input.h>
+#include <linux/gpio_buttons.h>
+
+#ifdef CONFIG_RALINK_DEV_GPIO_BUTTONS
+void __init ramips_register_gpio_buttons(int id,
+                                        unsigned poll_interval,
+                                        unsigned nbuttons,
+                                        struct gpio_button *buttons);
+#else
+static inline void ramips_register_gpio_buttons(int id,
+                                               unsigned poll_interval,
+                                               unsigned nbuttons,
+                                               struct gpio_button *buttons);
+{
+}
+#endif
+
+#endif /* __ASM_MACH_RALINK_DEV_GPIO_BUTTONS_H */
index fac5c7b..c30dbe1 100644 (file)
@@ -48,6 +48,9 @@ config SOC_RT305X
        select SYS_HAS_EARLY_PRINTK
        select MIPS_MACHINE
 
+config RALINK_DEV_GPIO_BUTTONS
+       def_bool n
+
 config RALINK_DEV_GPIO_LEDS
        def_bool n
 
index c2cf48b..adab85f 100644 (file)
@@ -1,7 +1,7 @@
 #
 # Makefile for the Ralink common stuff
 #
-# Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+# Copyright (C) 2009-2010 Gabor Juhos <juhosg@openwrt.org>
 #
 # This program is free software; you can redistribute it and/or modify it
 # under the terms of the GNU General Public License version 2 as published
@@ -9,4 +9,5 @@
 
 obj-y  := prom.o setup.o intc.o gpio.o
 
+obj-$(CONFIG_RALINK_DEV_GPIO_BUTTONS)  += dev-gpio-buttons.o
 obj-$(CONFIG_RALINK_DEV_GPIO_LEDS)     += dev-gpio-leds.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/common/dev-gpio-buttons.c b/target/linux/ramips/files/arch/mips/ralink/common/dev-gpio-buttons.c
new file mode 100644 (file)
index 0000000..f323001
--- /dev/null
@@ -0,0 +1,57 @@
+/*
+ *  Ralink SoC GPIO button support
+ *
+ *  Copyright (C) 2010 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include "linux/init.h"
+#include <linux/platform_device.h>
+
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+
+void __init ramips_register_gpio_buttons(int id,
+                                        unsigned poll_interval,
+                                        unsigned nbuttons,
+                                        struct gpio_button *buttons)
+{
+       struct platform_device *pdev;
+       struct gpio_buttons_platform_data pdata;
+       struct gpio_button *p;
+       int err;
+
+       p = kmalloc(nbuttons * sizeof(*p), GFP_KERNEL);
+       if (!p)
+               return;
+
+       memcpy(p, buttons, nbuttons * sizeof(*p));
+
+       pdev = platform_device_alloc("gpio-buttons", id);
+       if (!pdev)
+               goto err_free_buttons;
+
+       memset(&pdata, 0, sizeof(pdata));
+       pdata.poll_interval = poll_interval;
+       pdata.nbuttons = nbuttons;
+       pdata.buttons = p;
+
+       err = platform_device_add_data(pdev, &pdata, sizeof(pdata));
+       if (err)
+               goto err_put_pdev;
+
+
+       err = platform_device_add(pdev);
+       if (err)
+               goto err_put_pdev;
+
+       return;
+
+err_put_pdev:
+       platform_device_put(pdev);
+
+err_free_buttons:
+       kfree(p);
+}
index f2e82a3..2f5afae 100644 (file)
@@ -113,6 +113,7 @@ CONFIG_PHYLIB=y
 # CONFIG_PNX8550_JBS is not set
 # CONFIG_PNX8550_STB810 is not set
 # CONFIG_PROBE_INITRD_HEADER is not set
+# CONFIG_RALINK_DEV_GPIO_BUTTONS is not set
 CONFIG_RALINK_DEV_GPIO_LEDS=y
 CONFIG_RALINK_RT288X=y
 # CONFIG_RALINK_RT305X is not set
index e0e0e16..b0c1636 100644 (file)
@@ -116,6 +116,7 @@ CONFIG_PHYLIB=y
 # CONFIG_PNX8550_JBS is not set
 # CONFIG_PNX8550_STB810 is not set
 # CONFIG_PROBE_INITRD_HEADER is not set
+# CONFIG_RALINK_DEV_GPIO_BUTTONS is not set
 CONFIG_RALINK_DEV_GPIO_LEDS=y
 CONFIG_RALINK_RT288X=y
 # CONFIG_RALINK_RT305X is not set
index 9ba59af..59c2de2 100644 (file)
@@ -109,6 +109,7 @@ CONFIG_PHYLIB=y
 # CONFIG_PNX8550_JBS is not set
 # CONFIG_PNX8550_STB810 is not set
 # CONFIG_PROBE_INITRD_HEADER is not set
+# CONFIG_RALINK_DEV_GPIO_BUTTONS is not set
 CONFIG_RALINK_DEV_GPIO_LEDS=y
 # CONFIG_RALINK_RT288X is not set
 CONFIG_RALINK_RT305X=y
index 76e97e3..2576681 100644 (file)
@@ -112,6 +112,7 @@ CONFIG_PHYLIB=y
 # CONFIG_PNX8550_JBS is not set
 # CONFIG_PNX8550_STB810 is not set
 # CONFIG_PROBE_INITRD_HEADER is not set
+# CONFIG_RALINK_DEV_GPIO_BUTTONS is not set
 CONFIG_RALINK_DEV_GPIO_LEDS=y
 # CONFIG_RALINK_RT288X is not set
 CONFIG_RALINK_RT305X=y