build: increase file descriptor count limit for the build, some systems (e.g. Mac...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 31 Oct 2012 00:23:47 +0000 (00:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 31 Oct 2012 00:23:47 +0000 (00:23 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34023 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/toplevel.mk

index f44dc81..19ed8cb 100644 (file)
@@ -51,6 +51,8 @@ export SCAN_COOKIE
 
 SUBMAKE:=umask 022; $(SUBMAKE)
 
+ULIMIT_FIX=_limit=`ulimit -n`; [ "$$_limit" = "unlimited" -o "$$_limit" -ge 1024 ] || ulimit -n 1024;
+
 prepare-mk: FORCE ;
 
 prepare-tmpinfo: FORCE
@@ -149,7 +151,7 @@ prereq:: prepare-tmpinfo .config
                        echo "WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!"; \
                fi \
        )
-       @+$(SUBMAKE) -r $@
+       @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
 
 help:
        cat README