odhcp6c: Add support for userclass and vendorclass
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Feb 2014 14:56:37 +0000 (14:56 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 5 Feb 2014 14:56:37 +0000 (14:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39478 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index b7a1513..709746f 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2014-01-31
+PKG_VERSION:=2014-02-05
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=b4a0f3d74b04074eae21e88fbf5b8f2ddc150f86
+PKG_SOURCE_VERSION:=db2915f095db17cb10bf67d5b3bf67f891d45625
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
index cffb3ec..387fa30 100755 (executable)
@@ -16,14 +16,16 @@ proto_dhcpv6_init_config() {
        proto_config_add_string "iface_dslite"
        proto_config_add_string "ifaceid"
        proto_config_add_string "sourcerouting"
+       proto_config_add_string "userclass"
+       proto_config_add_string "vendorclass"
 }
 
 proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting
-       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting
+       local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting userclass vendorclass
+       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting userclass vendorclass
 
 
        # Configure
@@ -43,6 +45,10 @@ proto_dhcpv6_setup() {
 
        [ -n "$ifaceid" ] && append opts "-i$ifaceid"
 
+       [ -n "$vendorclass" ] && append opts "-V$vendorclass"
+
+       [ -n "$userclass" ] && append opts "-u$userclass"
+
        for opt in $reqopts; do
                append opts "-r$opt"
        done