ramips: fix Olimex models, images and profiles names
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 05:59:29 +0000 (05:59 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 05:59:29 +0000 (05:59 +0000)
Official names for RT5350F based OLinuXino products are "RT5350F-OLinuXino{,-EVB}" as on official manufacturer website.
The following patch:
 * changes board names from "olinuxino-rt5350f{,-evb}" to "rt5350f-olinuxino{,-evb}"
 * changes filenames of dts and profile files
 * changes image filenames

for Olimex RT5350F-OLinuXino{,-EVB} devices.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46623 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/OLINUXINO-RT5350F-EVB.dts [deleted file]
target/linux/ramips/dts/OLINUXINO-RT5350F.dts [deleted file]
target/linux/ramips/dts/RT5350F-OLINUXINO-EVB.dts [new file with mode: 0644]
target/linux/ramips/dts/RT5350F-OLINUXINO.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/olinuxino-rt5350f-evb.mk [deleted file]
target/linux/ramips/rt305x/profiles/olinuxino-rt5350f.mk [deleted file]
target/linux/ramips/rt305x/profiles/rt5350f-olinuxino-evb.mk [new file with mode: 0644]
target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk [new file with mode: 0644]

index aff380b..58d7fc9 100755 (executable)
@@ -247,11 +247,11 @@ ramips_board_detect() {
        *"Omnima MiniPlug")
                name="omni-plug"
                ;;
-       *"OLinuXino-RT5350F")
-               name="olinuxino-rt5350f"
+       *"Olimex RT5350F-OLinuXino")
+               name="rt5350f-olinuxino"
                ;;
-       *"OLinuXino-RT5350F-EVB")
-               name="olinuxino-rt5350f-evb"
+       *"Olimex RT5350F-OLinuXino-EVB")
+               name="rt5350f-olinuxino-evb"
                ;;
        *"PBR-M1")
                name="pbr-m1"
index f78bc22..5242e46 100755 (executable)
@@ -77,8 +77,8 @@ platform_check_image() {
        omni-emb | \
        omni-emb-hpm | \
        omni-plug | \
-       olinuxino-rt5350f | \
-       olinuxino-rt5350f-evb | \
+       rt5350f-olinuxino | \
+       rt5350f-olinuxino-evb | \
        psr-680w | \
        px4885 | \
        re6500 | \
diff --git a/target/linux/ramips/dts/OLINUXINO-RT5350F-EVB.dts b/target/linux/ramips/dts/OLINUXINO-RT5350F-EVB.dts
deleted file mode 100644 (file)
index 0a7d748..0000000
+++ /dev/null
@@ -1,102 +0,0 @@
-/dts-v1/;
-
-/include/ "rt5350.dtsi"
-
-/ {
-       compatible = "RT5350F-OLINUXINO", "ralink,rt5350-soc";
-       model = "RT5350F-OLINUXINO";
-
-       palmbus@10000000 {
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "s25fl064k";
-                               reg = <0 0>;
-                               linux,modalias = "m25p80", "s25fl064k";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "u-boot";
-                                       reg = <0x0 0x30000>;
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       label = "u-boot-env";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       label = "factory";
-                                       reg = <0x40000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       label = "firmware";
-                                       reg = <0x50000 0x3b0000>;
-                               };
-                       };
-               };
-
-               gpio1: gpio@660 {
-                       status = "okay";
-               };
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "jtag", "rgmii", "mdio", "uartf";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-       };
-
-       esw@10110000 {
-               ralink,portmap = <0x2f>;
-               ralink,led_polarity = <0x17>;
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       ehci@101c0000 {
-               status = "okay";
-       };
-
-       ohci@101c1000 {
-               status = "okay";
-       };
-
-       gpio_export {
-               compatible = "gpio-export";
-               #size-cells = <0>;
-
-               relay1 {
-                       gpio-export,name = "gpio12";
-                       gpio-export,output = <0>;
-                       gpios = <&gpio0 12 0>;
-               };
-
-               relay2 {
-                       gpio-export,name = "gpio14";
-                       gpio-export,output = <0>;
-                       gpios = <&gpio0 14 0>;
-               };
-
-               button {
-                       gpio-export,name = "button";
-                       gpios = <&gpio0 0 1>;
-               };
-       };
-};
diff --git a/target/linux/ramips/dts/OLINUXINO-RT5350F.dts b/target/linux/ramips/dts/OLINUXINO-RT5350F.dts
deleted file mode 100644 (file)
index a259693..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-/dts-v1/;
-
-/include/ "rt5350.dtsi"
-
-/ {
-       compatible = "RT5350F-OLINUXINO", "ralink,rt5350-soc";
-       model = "RT5350F-OLINUXINO";
-
-       palmbus@10000000 {
-               spi@b00 {
-                       status = "okay";
-
-                       m25p80@0 {
-                               #address-cells = <1>;
-                               #size-cells = <1>;
-                               compatible = "s25fl064k";
-                               reg = <0 0>;
-                               linux,modalias = "m25p80", "s25fl064k";
-                               spi-max-frequency = <10000000>;
-
-                               partition@0 {
-                                       label = "u-boot";
-                                       reg = <0x0 0x30000>;
-                                       read-only;
-                               };
-
-                               partition@30000 {
-                                       label = "u-boot-env";
-                                       reg = <0x30000 0x10000>;
-                                       read-only;
-                               };
-
-                               factory: partition@40000 {
-                                       label = "factory";
-                                       reg = <0x40000 0x10000>;
-                                       read-only;
-                               };
-
-                               partition@50000 {
-                                       label = "firmware";
-                                       reg = <0x50000 0x3b0000>;
-                               };
-                       };
-               };
-
-               gpio1: gpio@660 {
-                       status = "okay";
-               };
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "jtag", "rgmii", "mdio", "uartf";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-       };
-
-       esw@10110000 {
-               ralink,portmap = <0x2f>;
-               ralink,led_polarity = <0x17>;
-       };
-
-       wmac@10180000 {
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       ehci@101c0000 {
-               status = "okay";
-       };
-
-       ohci@101c1000 {
-               status = "okay";
-       };
-};
diff --git a/target/linux/ramips/dts/RT5350F-OLINUXINO-EVB.dts b/target/linux/ramips/dts/RT5350F-OLINUXINO-EVB.dts
new file mode 100644 (file)
index 0000000..17fa66f
--- /dev/null
@@ -0,0 +1,102 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "RT5350F-OLINUXINO-EVB", "ralink,rt5350-soc";
+       model = "Olimex RT5350F-OLinuXino-EVB";
+
+       palmbus@10000000 {
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "s25fl064k";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "s25fl064k";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x3b0000>;
+                               };
+                       };
+               };
+
+               gpio1: gpio@660 {
+                       status = "okay";
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x2f>;
+               ralink,led_polarity = <0x17>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       gpio_export {
+               compatible = "gpio-export";
+               #size-cells = <0>;
+
+               relay1 {
+                       gpio-export,name = "gpio12";
+                       gpio-export,output = <0>;
+                       gpios = <&gpio0 12 0>;
+               };
+
+               relay2 {
+                       gpio-export,name = "gpio14";
+                       gpio-export,output = <0>;
+                       gpios = <&gpio0 14 0>;
+               };
+
+               button {
+                       gpio-export,name = "button";
+                       gpios = <&gpio0 0 1>;
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/RT5350F-OLINUXINO.dts b/target/linux/ramips/dts/RT5350F-OLINUXINO.dts
new file mode 100644 (file)
index 0000000..40caa6b
--- /dev/null
@@ -0,0 +1,80 @@
+/dts-v1/;
+
+/include/ "rt5350.dtsi"
+
+/ {
+       compatible = "RT5350F-OLINUXINO", "ralink,rt5350-soc";
+       model = "Olimex RT5350F-OLinuXino";
+
+       palmbus@10000000 {
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "s25fl064k";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80", "s25fl064k";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0x3b0000>;
+                               };
+                       };
+               };
+
+               gpio1: gpio@660 {
+                       status = "okay";
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "jtag", "rgmii", "mdio", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+       };
+
+       esw@10110000 {
+               ralink,portmap = <0x2f>;
+               ralink,led_polarity = <0x17>;
+       };
+
+       wmac@10180000 {
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+};
index af09f27..e3ff8e6 100644 (file)
@@ -578,16 +578,16 @@ Image/Build/Profile/OMNI-EMB=$(call BuildFirmware/Default8M/$(1),$(1),omni-emb,O
 
 Image/Build/Profile/OMNI-PLUG=$(call BuildFirmware/Default8M/$(1),$(1),omni-plug,OMNI-PLUG)
 
-Image/Build/Profile/OLINUXINO-RT5350F=$(call BuildFirmware/Default8M/$(1),$(1),olinuxino-rt5350f,OLINUXINO-RT5350F)
-
-Image/Build/Profile/OLINUXINO-RT5350F-EVB=$(call BuildFirmware/Default8M/$(1),$(1),olinuxino-rt5350f-evb,OLINUXINO-RT5350F-EVB)
-
 Image/Build/Profile/PSR-680W=$(call BuildFirmware/Default4M/$(1),$(1),psr-680w,PSR-680W)
 
 Image/Build/Profile/PWH2004=$(call BuildFirmware/Default8M/$(1),$(1),pwh2004,PWH2004)
 
 Image/Build/Profile/PX4885=$(call BuildFirmware/DefaultDualSize/$(1),$(1),px4885,PX4885)
 
+Image/Build/Profile/RT5350F-OLINUXINO=$(call BuildFirmware/Default8M/$(1),$(1),rt5350f-olinuxino,RT5350F-OLINUXINO)
+
+Image/Build/Profile/RT5350F-OLINUXINO-EVB=$(call BuildFirmware/Default8M/$(1),$(1),rt5350f-olinuxino-evb,RT5350F-OLINUXINO-EVB)
+
 Image/Build/Profile/RTG32B1=$(call BuildFirmware/Default4M/$(1),$(1),rt-g32-b1,RT-G32-B1)
 
 Image/Build/Profile/RTN10PLUS=$(call BuildFirmware/Default4M/$(1),$(1),rt-n10-plus,RT-N10-PLUS)
@@ -744,11 +744,11 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/NW718,$(1))
        $(call Image/Build/Profile/OMNI-EMB,$(1))
        $(call Image/Build/Profile/OMNI-PLUG,$(1))
-       $(call Image/Build/Profile/OLINUXINO-RT5350F,$(1))
-       $(call Image/Build/Profile/OLINUXINO-RT5350F-EVB,$(1))
        $(call Image/Build/Profile/PSR-680W,$(1))
        $(call Image/Build/Profile/PWH2004,$(1))
        $(call Image/Build/Profile/PX4885,$(1))
+       $(call Image/Build/Profile/RT5350F-OLINUXINO,$(1))
+       $(call Image/Build/Profile/RT5350F-OLINUXINO-EVB,$(1))
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/RTN10PLUS,$(1))
        $(call Image/Build/Profile/RT-N13U,$(1))
diff --git a/target/linux/ramips/rt305x/profiles/olinuxino-rt5350f-evb.mk b/target/linux/ramips/rt305x/profiles/olinuxino-rt5350f-evb.mk
deleted file mode 100644 (file)
index 1bf9829..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/OLINUXINO-RT5350F-EVB
-       NAME:=OLinuXino-RT5350F-EVB
-       PACKAGES:=\
-               kmod-usb-core kmod-usb-ohci kmod-usb2 \
-               kmod-i2c-core kmod-i2c-ralink \
-               kmod-spi-dev
-endef
-
-define Profile/OLINUXINO-RT5350F/Description
-       Package set for OLinuXino-RT5350F-EVB board
-endef
-
-$(eval $(call Profile,OLINUXINO-RT5350F-EVB))
-
diff --git a/target/linux/ramips/rt305x/profiles/olinuxino-rt5350f.mk b/target/linux/ramips/rt305x/profiles/olinuxino-rt5350f.mk
deleted file mode 100644 (file)
index af24c58..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/OLINUXINO-RT5350F
-       NAME:=OLinuXino-RT5350F
-       PACKAGES:=\
-               kmod-usb-core kmod-usb-ohci kmod-usb2 \
-               kmod-i2c-core kmod-i2c-ralink \
-               kmod-spi-dev
-endef
-
-define Profile/OLINUXINO-RT5350F/Description
-       Package set for OLinuXino-RT5350F board
-endef
-
-$(eval $(call Profile,OLINUXINO-RT5350F))
diff --git a/target/linux/ramips/rt305x/profiles/rt5350f-olinuxino-evb.mk b/target/linux/ramips/rt305x/profiles/rt5350f-olinuxino-evb.mk
new file mode 100644 (file)
index 0000000..61f5ddb
--- /dev/null
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RT5350F-OLINUXINO-EVB
+       NAME:=RT5350F-OLinuXino-EVB
+       PACKAGES:=\
+               kmod-usb-core kmod-usb-ohci kmod-usb2 \
+               kmod-i2c-core kmod-i2c-ralink \
+               kmod-spi-dev
+endef
+
+define Profile/RT5350F-OLINUXINO-EVB/Description
+       Package set for RT5350F-OLinuXino-EVB board
+endef
+
+$(eval $(call Profile,RT5350F-OLINUXINO-EVB))
+
diff --git a/target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk b/target/linux/ramips/rt305x/profiles/rt5350f-olinuxino.mk
new file mode 100644 (file)
index 0000000..3b20190
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RT5350F-OLINUXINO
+       NAME:=RT5350F-OLinuXino
+       PACKAGES:=\
+               kmod-usb-core kmod-usb-ohci kmod-usb2 \
+               kmod-i2c-core kmod-i2c-ralink \
+               kmod-spi-dev
+endef
+
+define Profile/RT5350F-OLINUXINO/Description
+       Package set for RT5350F-OLinuXino board
+endef
+
+$(eval $(call Profile,RT5350F-OLINUXINO))