kernel: x86 remove dependency on ata-core and scsi-core
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Mar 2010 14:18:11 +0000 (14:18 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 21 Mar 2010 14:18:11 +0000 (14:18 +0000)
The x86 image includes the modules out of ata-core and scsi-core
directly in the kernel image. Do not depend on these packages, because
they are not build in a x86 image.
This fixes #6873

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20346 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/block.mk
package/kernel/modules/usb.mk

index 92b9e63..009a8e1 100644 (file)
@@ -10,7 +10,7 @@ BLOCK_MENU:=Block Devices
 define KernelPackage/ata-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Serial and Parallel ATA support
-  DEPENDS:=@PCI_SUPPORT @LINUX_2_6 +kmod-scsi-core @(!TARGET_ubicom32||!TARGET_etrax)
+  DEPENDS:=@PCI_SUPPORT @LINUX_2_6 +kmod-scsi-core @(!TARGET_ubicom32||!TARGET_etrax||!TARGET_x86)
   KCONFIG:=CONFIG_ATA
   FILES:=$(LINUX_DIR)/drivers/ata/libata.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,21,libata,1)
@@ -21,7 +21,7 @@ $(eval $(call KernelPackage,ata-core))
 
 define KernelPackage/ata/Depends
   SUBMENU:=$(BLOCK_MENU)
-  DEPENDS:=kmod-ata-core $(1)
+  DEPENDS:=!TARGET_x86:kmod-ata-core $(1)
 endef
 
 
@@ -302,6 +302,7 @@ $(eval $(call KernelPackage,ide-it821x))
 define KernelPackage/scsi-core
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=SCSI device support
+  DEPENDS:=@!TARGET_x86
   KCONFIG:= \
        CONFIG_SCSI \
        CONFIG_BLK_DEV_SD
@@ -451,7 +452,7 @@ $(eval $(call KernelPackage,axonram))
 define KernelPackage/libsas
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=SAS Domain Transport Attributes
-  DEPENDS:=+kmod-scsi-core @TARGET_x86
+  DEPENDS:=@TARGET_x86
   KCONFIG:=CONFIG_SCSI_SAS_LIBSAS \
        CONFIG_SCSI_SAS_ATTRS \
        CONFIG_SCSI_SAS_ATA=y \
index 816e7f1..251d666 100644 (file)
@@ -495,7 +495,7 @@ $(eval $(call KernelPackage,usb-serial-option))
 
 
 define KernelPackage/usb-storage
-$(call KernelPackage/usb/Depends,+kmod-scsi-core)
+$(call KernelPackage/usb/Depends,+!TARGET_x86:kmod-scsi-core)
   TITLE:=USB Storage support
   KCONFIG:=CONFIG_USB_STORAGE
   FILES:=$(LINUX_DIR)/drivers/usb/storage/usb-storage.$(LINUX_KMOD_SUFFIX)