cmake: fix ccache command when using host ccache (patch from #9611)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 24 Jul 2011 08:34:08 +0000 (08:34 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 24 Jul 2011 08:34:08 +0000 (08:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27742 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/cmake.mk

index 6c5b5eb..ad9744d 100644 (file)
@@ -15,9 +15,13 @@ ifeq ($(CONFIG_CCACHE),)
   CMAKE_CXX_COMPILER_ARG1:=
  endif
 else
-  CMAKE_C_COMPILER:=$(STAGING_DIR_HOST)/bin/ccache
+  CCACHE:=$(shell which ccache)
+  ifeq ($(CCACHE),)
+    CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
+  endif
+  CMAKE_C_COMPILER:=$(CCACHE)
   CMAKE_C_COMPILER_ARG1:=$(filter-out ccache,$(TARGET_CC))
-  CMAKE_CXX_COMPILER:=$(STAGING_DIR_HOST)/bin/ccache
+  CMAKE_CXX_COMPILER:=$(CCACHE)
   CMAKE_CXX_COMPILER_ARG1:=$(filter-out ccache,$(TARGET_CXX))
 endif